Reply To: Unable to use hardware acceleration (nvidia gpu)

Forums / NoMachine for Linux / Unable to use hardware acceleration (nvidia gpu) / Reply To: Unable to use hardware acceleration (nvidia gpu)

#28100
fra81
Moderator

It looks like libnvidia-encode.so can’t be loaded. The possible cause is that /usr/lib/x86_64-linux-gnu/nvidia/current/ is not in the library search path. You could try to create a symlink to that library:

sudo ln -s /usr/lib/x86_64-linux-gnu/nvidia/current/libnvidia-encode.so /usr/lib/x86_64-linux-gnu/libnvidia-encode.so

If that won’t work, please try to check permissions for that library and other libraries linked to this one (you can find such linked libraries with the ‘ldd libnvidia-encode.so’ command).