Reply To: Behavior of NX Server 3.5 doesn’t work in NX 4

Forums / NoMachine Cloud Server Products / Behavior of NX Server 3.5 doesn’t work in NX 4 / Reply To: Behavior of NX Server 3.5 doesn’t work in NX 4

#1445
Avatarsnejok
Participant

I tried it again and result is:

1. NXPlayer doesn’t show me all the desktop types available on that server”, but connects me after I click on  ‘Create a new virtual desktop’, but in https://www.nomachine.com/AR07K00681 wrote:

On the server side:
ConnectPolicy autocreate=0,autoconnect=1,desktop=0
On the player side, you will need to follow the same steps as above:

– When you connect for the first time to that server: Open NoMachine -> Click Add a computer -> Fill in IP and session name -> Connect -> Click on  ‘Create a new virtual desktop’.

In the next panel showing all the desktop types available on that server, check ‘Save this setting in the configuration file’.

Choose and create the desktop you want to connect.

– Disconnect the session by closing the window or disconnecting from the menu (ctrl-alt-0 ->

– Launch this connection again: you should be re-connected automatically to the virtual desktop you have created the first time.

Bolded options doesn’t show

 

2. Reconnection doesn’t work automatically: nxplayer shows me the running sessions (see screenshot)

 

Be also sure that the first time you connect, you check ‘Save this setting in the configuration file’ in the GUI.  Then disconnect and connect once again: you should now be able to reconnect the virtual desktop.

I’m really sure

 

 

Attachments: