Reply To: How do you specify X server DPI for session?

Forums / NoMachine for Windows / How do you specify X server DPI for session? / Reply To: How do you specify X server DPI for session?

#3503
Avatarthomase
Participant

I’m only a user and don’t have admin privileges on the server. Therefore I can’t create any files in the /usr/NX/etc directory.

Anyway, Xft.dpi can be changed on-the-fly (e.g. via the gnome-control-center). The X core font (xfs) DPI setting is something different and I believe it can only be specified when the X server starts. I thought the DPI settings in node.cfg controlled this instead of Xft.dpi. The reason I want to change it is because I run EDA tools, many of which use the legacy X font system instead of Xft/fontconfig. I think some of these tools assume 100 dpi for their default font sizes and don’t look right when the DPI is 75 instead.

If what you are saying is true, then how do I, as a user, set the X server DPI setting?

As a side note, I know that xrandr has a ‘–dpi’ switch, supposedly allowing modification of the X server DPI without restarting, but it doesn’t seem to work, at least in NX.

For reference, my NX session is “floating window” style and starts up with an xterm. I have checked the X server DPI setting with the following command:

> xdpyinfo | grep dot

resolution:    75×75 dots per inch

I can’t figure out a way to change it.