Reply To: How to setup server on Centos

Forums / NoMachine for Linux / How to setup server on Centos / Reply To: How to setup server on Centos

#424
Avatartitan
Participant

Jason,

open a console and run:

> ps auxwww| grep nxd

You should see nxd running with pid 17603. Can you see it?

AFAIR you said that you can connect to nxd when running the client on the same machine. It seems to me a trivial firewall problem, that is the connection on port 4000 is blocked before reaching nxd. It can be a security feature on your machine blocking connections to “unknown” services. The installation script adds all the required rules for SELinux and AppArmor. You disabled SELinux and this didn’t work either… I don’t think changing port will help, but…

Install netcat (nc) and run:

> nc -l 4012

Or some other port. Then on another machine:

> telnet server_machine 4012

Can you connect to this other port?

There is not much more that I can say. What I can suggest is:

– Tunnel the connection to that machine by ssh. See this post on how to do it:

https://www.nomachine.com/forums/forums/topic/unable-to-connect#post-228

– Install the Workstation evaluation. In the meanwhile we’ll investigate if there are similar reports from other users