Reply To: No active sessions in session list

Forums / NoMachine for Mac / No active sessions in session list / Reply To: No active sessions in session list

#1273
AvatarBritgirl
Keymaster

I tried to verify the difference using the MacOS and Linux clients (4.6.8) connecting to CentOS 6.5 and the default NX server from the distribution

This indicates that you could be connecting to an older NX server, possibly 3.5.0. You are therefore connecting using a connection file created with (let’s say) NX Client 3.5.0, in which the type of the desktop (e.g. KDE, Gnome etc) is always saved in the connection settings. Selecting the desktop type was a pre-requisite in 3.5.0 before logging in, in version 4 you select after authentication.

when I reconnected and did “Reset login information and preferences”, suddenly the session list appeared. This worked with both clients to the same host.

This means that the check box is doing its job properly 🙂 You can see the remote sessions list because when resetting the connection configuration, the session type you have already set in your “old connecting file” gets removed. The client can’t automatically start an “unknown” session and hence you get the option to run a new virtual desktop session. Maybe you had selected to create a new desktop and stored this setting in the connection file. Resetting this setting now, you get the options to reconnect to an existing desktop (the session list). Knowing that, if you find any inconsistency please let us know.

If you prefer this behaviour, you can uncheck the box “Save this setting in the configuration file” when selecting the type of virtual session to start. This way you will see the session list and the option to start a new session.

  • This reply was modified 6 years, 11 months ago by AvatarBritgirl.