Reply To: No session on headless server

Forums / NoMachine for Linux / No session on headless server / Reply To: No session on headless server

#4347
AvatarHaven
Contributor

Hello dtc42,

I logs you submitted we found that session because nxserver choose wrong X server to attach to. In user processes we can found two running X servers:

vnc4           Xvnc4 :1 -desktop localhost:1 (googlestudent) -auth /home/googlestudent/.Xauthority -geometry 1280×1024 -depth 16 -rfbwait 30000 -rfbauth /home/googlestudent/.vnc/passwd -rfbport 5901 -pn -fp /usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/,/usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/ -co /etc/X11/rgb

and

Xvfb            Xvfb :0 -auth /home/googlestudent/Xvfb-0.auth -screen 0 1280x1024x2

Please try to disable other X server before connecting to session or uncomment in node.cfg file key:

#
# Specify on which physical display the server must connect.
#
#DisplayDefault :0

Then nxserver will always choose X server with display defined in this key.

  • This reply was modified 6 years, 4 months ago by AvatarHaven.