Reply To: Setting up audio

Forums / NoMachine for Linux / Setting up audio / Reply To: Setting up audio

#5404
AvatarBritgirl
Keymaster

I’m now stuck here. I my Nxserver commands do not seem to be working. “NXserver command not found” each time I try to run this command. I haven’t installed any nxnodes yet as the same thing happens each time.

You need to execute the full path in version 4. So for example, /usr/NX/bin/nxserver –version.

My live NX system works fine but no Audio comes out from the VM out in the local machine. I’ve ticked the multimedia option on the VM client. The server is Centos 6.4 with pulseaudio installed and running. I checked the guide to enable Audio without ESD but step 1 confused me!

Audio works out of the box with version 4 so there should be no need to configure anything. What you write makes me think you are referring to version 3. Issues for version 3 are dealt with via the website (you can contact the team using the Contact Us link).  If, on the other hand, you have installed NoMachine 4 on your client and also NoMachine/NoMachine Workstation 4 on your server, and audio is not working, it will need further investigation.