Reply To: Unable to connect to NX Server

Forums / NoMachine for Linux / Unable to connect to NX Server / Reply To: Unable to connect to NX Server

#487
Avatartitan
Participant

I log on and the session hangs/disconnects

Hmmm, it seems to me that it is working fine. As far as I can see it is not hanging or disconnecting.

It seems to me similar to what another user described recently on the forum.

I don’t think it’s the same problem. What is crashing here seems to be KDE, so the X server restarts (hence possibly the disconnect because there is no server anymore). Then, after the X server is restarted (by the system, because you are at runlevel 5) KDE hangs. Unfortunately I have seen problems like this many many times.

Nov 5 14:47:37 linux-ypbf nxexec: PAM unable to dlopen(/lib64/security/pam_pwcheck.so)
Nov 5 14:47:37 linux-ypbf nxexec: PAM [error: /lib64/security/pam_pwcheck.so: undefined symbol: pam_syslog]
Nov 5 14:47:37 linux-ypbf nxexec: PAM adding faulty module: /lib64/security/pam_pwcheck.so

I checked with the author of the nxexec module and that message is just PAM not finding one of its modules (something outside our control). It’s not a crash. I don’t even think it’s a real problem. Probably just some PAM auth methods that can’t be used. Anyway if nxexec can’t use PAM it will fall back to shadow passwd. The remaining crashes are from KDE. This is not to say that it can’t be a NoMachine bug, of course. It’s just that it’s difficult to say from 1000 miles away. You should ensure that everything else is working, that your desktop environment runs 100% OK, that your KDE and Xorg and drivers are up-to-date. Debugging X problems is always a tedious process.