110 Connection time out on Android tablet

Forums / NoMachine for Mobile / 110 Connection time out on Android tablet

  • This topic has 6 replies, 3 voices, and was last updated 4 weeks ago by Avatarirek.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #34284
    AvatarGirgburg
    Participant

    Hello, when I have my Android tablet in the same network, connections work as intended, but I keep on running into 110 timeout errors when I try to remote in through my mobile network. Any help would be greatly appreciated, thanks!

    This is on the Android app and the latest version of the free Windows version of NoMachine.

    #34301
    Avatarfisherman
    Moderator

    About connecting to the NoMachine from external network I could ask you to check following article: How to connect to NoMachine when the server is behind a NAT router or a firewall.

    For easier access, NoMachine has open feature request that will help in your case, you can see more information at FR07J02731 – Creating the NoMachine Network service to let people connect to each other’s computers.

    #34307
    AvatarGirgburg
    Participant

    Hi there, thanks for the quick response!

    I think my problem is with Enabling UPnp/Nat-PMP port mapping, as when I check the server.cfg file “EnableUPnP NX” is set to “none”, but when I try to replace “none” with “for users connecting with the NX protocol” and save as the instructions on the first link advise, a window pops up that says I do not have permission to open/modify this file (please see attached). Is there any way to get past this?

    As for the second link, is there any estimation of when that service will be implemented? As that would be very helpful in my use case.

    Thank you!

    #34313
    Avatarfisherman
    Moderator

    Possibly easiest way to do it is to open NoMachine user Interface and edit port with enabling Gateway port. See more information at following article https://knowledgebase.nomachine.com/DT11R00177#3.2.

     

    Attachments:
    #34315
    AvatarGirgburg
    Participant

    Hello,

    Unfortunately when I clicked that, it says “failed to map the port on the gateway” (see attached). Is there any workaround for this?

    Thank you!

    Attachments:
    #34337
    Avatarfisherman
    Moderator

    upnp needs to be enabled on your home router, or you will need to do manual port forwarding. You will need to consult your router manual how to do it.

    #34338
    Avatarirek
    Participant

    Hello Girgburg,

    you wrote:

    but when I try to replace “none” with “for users connecting with the NX protocol”

    to be sure, can you please make sure that key EnableUPnP in server.cfg is set only to NX,
    so the whole line would looks like:

    EnableUPnP NX

    if not, please change to be like above.

    UPnP/NAT-PMP port mapping is enabled by default in NoMachine (free) version

    Please also make sure that on your router device, UPnP is enabled.
    If not, you will have to enable UPnP.

    Then on Windows: start cmd.exe as root (Administrator) and execute those commands

    # To start port mapping:
    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpmap

    #To display status and ports:
    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpstatus

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.