A new PulseAudio instance is created

Forums / NoMachine for Linux / A new PulseAudio instance is created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #25879
    ewired
    Participant

    I’m currently running Solus 4.1 on my client (KDE) and server (GNOME). After following the basic steps lined out for Solus at https://www.nomachine.com/AR07P00992 and successfully implementing the fix at https://www.nomachine.com/TR02R09538 I found problems with the PulseAudio support in NoMachine on Solus.

    To fix issues with the audio portion of the setup script, I soft linked /etc/pulse -> /usr/share/pulseaudio/. This appears to have allowed /usr/NX/scripts/setup/nxnode –audiosetup to continue with its setup routine successfully.

    Eventually, I found nxserver may be creating its own instance of PulseAudio and sending commands to it instead of the already running PulseAudio instance. I see in debug-level logs that it sends commands to create a null sink for NX’s output redirection, microphone remap, etc. Looking at pstree, I see two instances of PulseAudio. When restarting nxserver, there are no NoMachine-related streams in pavucontrol, and when I attempt to switch physical outputs, they all disappear and I’m left only with “Dummy Output.” This suggests that the nxserver instance of PulseAudio has taken over my audio devices and my desktop session has no control over nxserver’s instance of PulseAudio. Will I need to reconfigure my laptop (server) to have a system-wide PulseAudio instance? Is it possible that NoMachine can control the running instance from my desktop session?

    #25894
    kroy
    Contributor

    Thanks for the report. You can follow this trouble report: https://www.nomachine.com/TR03R09568 and use the notify me tool to know when a fix is available.

    Are you sure there were other physical outputs earlier? NoMachine is not invasive and not able to remove other modules from output list. You can shutdown NoMachine (sudo /usr/NX/bin/nxserver --shutdown) and respawn pulseaudio (execute pulseaudio -k and then pulseaudio -D). Is there sound on the machine desktop (physically, without involving NoMachine)? If not there won’t be in the NoMachine session neither.

    However audio in the connections will work when you create virtual desktop or if it’s free or NoMachine Enterprise Desktop version on the headless machine.

    #25910
    ewired
    Participant

    Sound is available on all physically connected/installed audio devices until I restart nxserver after logging in. Watching the output of pstree, it appears that a second instance of PulseAudio is being created shortly after the NoMachine player/client connects to the server. I’m working around the problem for now by disabling all audio capability in the NoMachine configuration and I’m using PulseAudio’s built-in ability to forward sound devices over the network with zeroconf discovery/paprefs. After configuring the NoMachine server to not use audio (AudioInterface disabled in node.cfg) there are no extra instances of PulseAudio being created upon connecting to it. I’m using the free edition with no headless servers or virtual displays, I have only ever connected after logging in to the desktop environment fully.

    #25921
    kroy
    Contributor

    Which pulseaudio version do you have? Is there any other audio framework runned there (for example phonon which is default on KDE)? Can you reverse changes in the node.cfg then enable debug (pulseaudio and NoMachine), reproduce and send it to forum[at]nomachine[dot]com?

    To enable debug on pulseaudio:
    – edit /etc/pulse/daemon.conf and change:

    ; log-target = auto
    ; log-level = notice

    to:

    log-target = auto
    log-level = debug

    Execute:

    pulseaudio -k
    pulseaudio -D

    Check logs and send to us file with output:

    cat /var/log/syslog* | grep -i pulse > /tmp/pulseaudio_logs.log
    How to collect server side NoMachine logs automatically:
    https://www.nomachine.com/DT10O00162

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as closed, you can't post.