"A software update is already running"

Forums / NoMachine Terminal Server Products / "A software update is already running"

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15493
    Derry
    Participant

    I’ve been unable to install 5.3.10. I have 5.3.9 running now, and Server Status/Preferences/Update shows “A software update is already running” and the “Check Now” button is grayed out. It’s been like that for at least a few days (probably much longer), and rebooting the computer doesn’t change things.

    I’m running NoMachine Workstation on OpenSuSE 13.2, x86_64, KDE. Nothing has changed on the computer for a long time (other than the fact that SuSE apparently no longer provides software repositories for this release). My NoMachine license is current.

    Thanks in advance. — Derry

    #15500
    kroy
    Contributor

    It looks, that some update process is working in background. We weren’t able to reproduce it on the same OS.

    Can you zip .nx folder (it’s in the home directory) and execute a stack /usr/NX/bin/nxclient –update process (you can use gdb, for example:

    pid=$(ps aux | grep [n]xclient | grep update | awk '{print $2}'); sudo gdb -p $pid -ex "set logging on" -ex "set pagination off" -ex "thread app all bt" -ex "set logging off" -ex quit

    it will create gdb.txt file with stack) from that OpenSUSE? Please do also screenshot that “update window” with greyed out “Check Now” button. All three files please send to forum[at]nomachine[dot]com.

    As a workaround you can download NoMachine Workstation from your customer area (if you have a subscription) and update manually inside console: sudo rpm -U <package_name>.

    #15611
    Derry
    Participant

    I’ve sent the requested information to the email address you specified. Sorry about the delay — I thought I would¬†receive an email if there were a reply.

    #15614
    Bilbotine
    Keymaster

    Hello Derry,

    Thank you for the logs, we received them.

    We will come back to you as soon as we have analysed them.

    #15624
    kroy
    Contributor

    We need to repeat the  test with complete set of logs if you are still able to reproduce problem.

    Before testing please set in the NoMachine Player to not remove logs after quitting. To do that – open NoMachine Player -> navigate to “Settings” -> click on “Privacy” -> and check “Don’t delete log files on exit”.

    Second thing is to paste here also output of the command: cat /usr/NX/etc/server.cfg | grep UpdateFrequency.

    Now reproduce the problem and list all the NoMachine processes that appear using ps aux | grep nx >> nx_processes_list.txt . Repeat the grep at one minute intervals for three minutes, so we can compare the lists.

    Send created file with the three outputs to forum[at]nomachine[dot]com. Please zip and send also .nx folder.

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.