Access multiple desktops via Internet

Forums / General Discussions / Access multiple desktops via Internet

This topic contains 1 reply, has 2 voices, and was last updated by Avatar kroy 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #23814
    Avatar
    MotoTom
    Participant

    I am a NoMachine newbie, migrating from (other remote access tool) because they are treating me as a commercial customer. I am using the free version. I work on some laptops owned by elderly friends who not at all tech savvy. One machine run Linux Mint 19.1 and the other runs Linux Lite 3.8. They are on an ATT network and behind a 2Wire 3018HGV router.

    I was able to successfully install NoMachine on both but I do not get an external IP Address with port number. All that shows up are the internal IP Addresses. I did get one to work by setting up a NoMachine port on the router using port 4000 but that is assigned only to the LinuxLite laptop. It doesn’t help getting to the Linux Mint machine.

    I’ve read the various documents about how to configure the router if it doesn’t natively support uPnP or NAT-PMP but nothing tells what to do to solve my problem. Attached is a copy of the page I need to fill in to install a under-defined service.

    Many thanks for reading. Any suggestions are greatly appreciated.

    #23829
    Avatar
    kroy
    Contributor

    Probably it was typo with the router model number. Isn’t it 3801hgv? You can follow that guide: https://portforward.com/2wire/3801hgv/

    1. Set static IP for machine with nxserver.

    2. Log in to the router, and then select your computer (with nxserver). Then navigate to panel from your screenshot, set some Application Name (for example: NoMachine TCP and NoMachine UDP) and choose 4000 in the Port field choose 4000. Create two applications separately with this method – for TCP and UDP.

    3. Confirm changes. Go Back and add just created applications to the Hosted Applications box.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.