Agent forwarding for Terminal Nodes

Forums / NoMachine Terminal Server Products / Agent forwarding for Terminal Nodes

This topic contains 2 replies, has 2 voices, and was last updated by Avatar cdelcano 1 month, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23721
    Avatar
    cdelcano
    Participant

    Hello,

    I have a test setup with one Enterprise Terminal Server and two Terminal Nodes.

    The nodes have been added to the Terminal server with SSH protocol.

    When connecting with the NoMachine client from my Windows machine, with a private key file and agent forwarding, the key is only forwarded when the virtual desktop runs on the Terminal Server. When the virtual desktop runs on one of the Terminal nodes, the key is not forwarded at all.

    Is there a configuration setting that I’m missing? Is this a known bug? (I’ve searched, but can’t find any reference to this).

    I have tested this through a direct SSH connection, and the problem only applies for NoMachine connections.

    Terminal Server and Terminal Nodes on CentOS Linux release 7.7.1908

    nomachine-enterprise-terminal-server-6.8.1-1.x86_64 (in evaluation mode)

    nomachine-terminal-server-node-6.8.1-1.x86_64 (in evaluation mode)

    NoMachine 6.7.6 client for Windows 10

    Many thanks,

    Cristina

    #23775
    Avatar
    Britgirl
    Keymaster

    This is planned. Please see:

    Forwarding SSH agent authentication to the remote nodes
    https://www.nomachine.com/FR09Q03878

    #23776
    Avatar
    cdelcano
    Participant

    Thanks Britgirl, they just opened that one 🙂

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.