Alpine NoMachine installation

Forums / NoMachine for Linux / Alpine NoMachine installation

Tagged: ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #40089
    mckaygerhard
    Participant

    Hi, long time to the point.. I tried again .. this time Alpine 3.15 and using command line:

    /usr/NX/nxserver –install redhat

    when was at the compiling modules of usb, got a output rare:

    NX> 700 Compiling the USB module.
    Illegal option -p

    cheeking at the output note this log using

    NX> 700 Installing XDG Mime.
    NX> 700 Running: /usr/bin/xdg-desktop-menu install –mode system ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxs.desktop’ ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxw.desktop’ ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxv.desktop’ ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxr.desktop’.
    NX> 700 Result: OK.
    NX> 700 Compiling the USB module.
    NX> 700 ERROR: sudo command not found.
    NX> 700 Running: /bin/cp -f ‘/usr/NX/share/mimetypes.sample’ ‘/usr/NX/share/mimetypes’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/mkdir -p ‘/media/nomachine’.
    NX> 700 Result: OK.

    I see that the only “-p” is the mkdir command but that has no sense because I am not using the busybox flavor.. I already installed all the tools from coreutils and bash also. But the crapo of sudo its invoked.. sop install the wrapper for

    following the guide in https://t.me/alpine from codeberg.org/alpine/alpine-wiki i installed the doas-sudo-shim package and redone the install, now got this:

    awk: /usr/NX/etc/server.cfg: No such file or directory
    Error relocating /usr/NX/lib/libcrypt.so.1: __stpncpy: symbol not found
    NX> 700 Starting install at: Mon Sep 12 02:16:44 2022.
    NX> 700 Installing: nxclient version: 7.10.1.
    NX> 700 Using installation profile: Red Hat.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Compiling the USB module.
    Illegal option -p

     

    It seems there is some error but the scripts do not give me enough output in the log.. cos now , please any help this time dont do the typical “closed due lack of response”

    this time the output at the log do not show errors.. the complete output is:

    NX> 700 Installing NoMachine from: nomachine_7.10.1_1_x86_64.tar.gz package.
    NX> 700 System information: linux 3.15.5 Linux venenux-casa2 5.15.55-0-lts #1-Alpine SMP Tue, 19 Jul 2022 14:43:02 +0000 x86_64 GNU/Linux.
    NX> 700 Running: /bin/rm -f ‘/usr/share/applications/NoMachine-nxr.desktop’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/etc/NX/server/localhost/client.cfg’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/scripts/restricted/nxfunct.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 744 ‘/usr/NX/scripts/restricted/nxfunct.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/scripts/restricted/nxusb.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 744 ‘/usr/NX/scripts/restricted/nxusb.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/scripts/restricted/nxusb.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/scripts/restricted/nxtun.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 744 ‘/usr/NX/scripts/restricted/nxtun.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/scripts/restricted/nxtun.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/bin/nxexec’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 555 ‘/usr/NX/bin/nxexec’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/bin/nxexec’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/bin/nxfsm’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 555 ‘/usr/NX/bin/nxfsm’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/bin/nxfsm’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/scripts/restricted/nxtun.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 744 ‘/usr/NX/scripts/restricted/nxtun.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/scripts/restricted/nxtun.sh’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/bin/nxexec’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 555 ‘/usr/NX/bin/nxexec’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/bin/nxexec’.
    NX> 700 Result: OK.
    NX> 700 Installing XDG Mime.
    NX> 700 Running: /usr/bin/xdg-desktop-menu install –mode system ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxs.desktop’ ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxw.desktop’ ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxv.desktop’ ‘/usr/NX/share/applnk/client/xdg/NoMachine-nxr.desktop’.
    NX> 700 Result: OK.
    NX> 700 Compiling the USB module.
    NX> 700 USB module has been installed successfully.
    NX> 700 Running: /bin/cp -f ‘/usr/NX/share/mimetypes.sample’ ‘/usr/NX/share/mimetypes’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 777 ‘/media/nomachine’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/etc/version’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 444 ‘/usr/NX/etc/version’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown root:root ‘/usr/NX/etc/update.cfg’.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chmod 644 ‘/usr/NX/etc/update.cfg’.
    NX> 700 Result: OK.

    and installer just hangs.. I cannot track the “-p” parameter.. just like mkdir and nothing more..

    #40316
    Britgirl
    Keymaster

    Hi, thanks for taking the time to report this. From the log it seems that you need to install gcc make and headers. Take a look at the article here about USB:

    What to do if USB support is disabled on Linux with NoMachine 6 or later installed
    https://kb.nomachine.com/AR12J00658

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.