ALT-GR + tilde, SPACEBAR does not work as it should

Forums / NoMachine for Linux / ALT-GR + tilde, SPACEBAR does not work as it should

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1162
    Avatarwernermaes
    Participant

    Hello

    When I type ALT-GR + tilde, SPACEBAR: I get nothing. I should get  ~.

    However when I press ALT-GR + tilde twice followed by SPACEBAR I get ~~

    If I run xev at the same time, you can easily that if you type ALT-GR you get

    KeyPress event, serial 33, synthetic NO, window 0x3c00001,
    root 0xfd, subw 0x0, time 3256131241, (179,-11), root:(183,92),
    state 0x2010, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

    but if you press the tilde key (ALT-GR key not released) nothing happens.

     

    client version 4.0.367

    server version 4.0.367

    #1171
    Avatarfra81
    Moderator

    Hello

    Just tried on Ubuntu 12.04 in Unity from Windows 7 and worked perfectly fine. Can you tell me more about your environment?

    Please specify the keyboard layout in use on client and on server and also:

    – Whether the problem arises connecting to a physical or a virtual display.
    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    #1177
    Avatarwernermaes
    Participant

    Environment:

    Server RHEL 6.5, keyboard layout: Belgium, Gnome virtual desktop session

    Client: Windows 7, keyboard layout: Belgian period.

    Do you need more info?

    Kind regards

     

    #1186
    Avatarfra81
    Moderator

    See? It was easy. I get the same with the Belgian keyboard. I opened a TR:

    https://www.nomachine.com/TR12K04110

    You can track it and see when it’s resolved.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as closed, you can't post.