Alternate server key auth failed

Forums / General Discussions / Alternate server key auth failed

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8929
    Avatarcyconical
    Participant

    Hey everyone!

    I’m quite new to NX administration. I want to provide a NX session file that comes with an alternate server key in connecting to the server via SSH using the NoMachine login. Therefore I wrote the path to the authentication key into the .nxs file, but unfortunately the session doesn’t find the key and doesn’t connect to the server. I have to choose the file manually to build the connection, though the path is exactly the same like i wrote it in the nxs file.

    Can someone tell why the NX Client doesn’t recognize the path or does someone know any solution?

    Thanks in advance!c.

    ——————–

    NoMachine: 5.0.43 with player 4.4.12
    Server: Debian 8.1 jessie

    #8959
    Avatarcyconical
    Participant

    Ok, I found a solution.

    I put the key into the .nxs file (<option key=”Public Key” value=”…..”>) and replaced the spaces in it with “$ # x a ;” (without the spaces between the chars, I noted that when I write it without spaces, it is not shown properly). A separate key file is not needed anymore.

    • This reply was modified 5 years, 6 months ago by Avatarcyconical.
    • This reply was modified 5 years, 6 months ago by Avatarcyconical.
    #8979
    Avatarcyconical
    Participant

    It should be “ ”

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.