Altgr keys in Web client

Forums / NoMachine for Windows / Altgr keys in Web client

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12829
    swizzly
    Participant

    Hi,

    The altgr+key combinations do not work in the NoMachine Webclient as expected e.g. altgr+7 which should result in a pipe character on a Swiss German keyboard layout. I tried several combinations, but none of them seem to work. The virtual keyboard, that works as expected, but of course it cannot really substitute the real keyboard. I noticed, if I have NoMachines virtual keyboard on the screen it detects (the keys get colored) the key-pushes on the HW keyboard correctly, but no output is generated in the text window.

    I analyzed the issue using the “xev” application on Linux, and I found the following:

    1) using normal NoMachine client and pushing the altgr+7, that results in the pipe “|” character looks like this:

    KeyPress event, serial 38, synthetic NO, window 0x1e00001,
    root 0xf3, subw 0x0, time 120261643, (1861,-300), root:(1863,603),
    state 0x90, keycode 16 (keysym 0x7c, bar), same_screen YES,
    XKeysymToKeycode returns keycode: 10
    XLookupString gives 1 bytes: (7c) “|”
    XmbLookupString gives 1 bytes: (7c) “|”
    XFilterEvent returns: False

    2) using NoMachine webclient and pushing altgr+7 generates this output:

    KeyPress event, serial 35, synthetic NO, window 0x1e00001,
    root 0xf3, subw 0x0, time 120261435, (1861,-300), root:(1863,603),
    state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

    I use NoMachine Cloud Server-5.1.54-2.x86_64 on a Red Hat Enterprise Linux v6.8 server, on the client side I use Internet Explorer 11.0.9600 on Windows 7 PC.

    Cheers

    #12842
    Shoti
    Contributor

    Hi swizzly,

    Thank you for reporting this issue and for your detailed report.

    We created a trouble report for this issue and our developers are already working on a solution. You can access the trouble report here: https://www.nomachine.com/TR11N07320

    Please note you can check the box “Notify me when the TR is closed” and an email will be sent to you when a fix for the trouble report will be closed released.

    #13052
    Britgirl
    Keymaster

    Update your installation to 5.1.62, a fix has been released.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.