AltGr+0 opens system overlay

Forums / NoMachine for Linux / AltGr+0 opens system overlay

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2880
    bratell
    Participant

    I come from a country where several important characters such as {}, $, ~ and € are access by pressing the AltGr key and a digit key. For instance } is AltGr+0.

    When I press AltGr+0 in my Windows machine logged into a Linux (Ubuntu 12.04 LTS), NoMachine opens the system settings menu. I have not figured out any way to produce a } character so I copy/paste it around. Annoying since I program in languages full of } characters.

    AltGr+9 -> { works well. It’s just AltGr+0 that fails.

    Also, how do I close that system overlay menu with the keyboard?

     

    Versions:

    Local Windows 4.0.370

    Remote Linux 4.0.370

     

     

    #2885
    Britgirl
    Keymaster

    AltGr+9 -> { works well. It’s just AltGr+0 that fails.

    Go in to the player settings -> Input  and change the hot-key combination you use to get the NoMachine session menu. You can also uncheck it if you prefer to just use the page-peel and leave all your keyboard free.

    Also, how do I close that system overlay menu with the keyboard?

    We can add the possibility to close the menu using the keyboard, perhaps ‘Esc’?

     

    #2937
    bratell
    Participant

    Thanks, unsetting the key worked. The keybinding to open the menu is Alt+Ctrl+0 (which I’ve understood is easily confused with AltGr+0 because NoMachine is not the first program to have had such a bug).

    I think having Esc close the menu would be a good thing. Good idea.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.