Alt+Tab and Ctrl+Tab doesn’t work when I connect to Windows system

Forums / NoMachine for Mac / Alt+Tab and Ctrl+Tab doesn’t work when I connect to Windows system

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7318
    puttime
    Participant

    I’m running NoMachine client on my MAC.

    I can connect to a Windows system running the NoMachine-server.

    No problems there.

    But keyboard shortcuts like “Alt+Tab” and “Ctrl+Tab” which is used to extensively in Windows, doesn’t work.

    That’s because the “alt” key on MAC is actually the “option” key, which is equivalent to F10 on Windows.

     

    Please help…..

    #7326
    graywolf
    Moderator

    Thanks for reporting. I can reproduce, actually we have issues with those shortcuts on Windows server. I’m going to create a Trouble Report about this issue.

    #7330
    puttime
    Participant

    But these are basic use cases. They should have been built in as features.

    Anyways looking for a solution quick, since i’m kind of depending on !Machine.

     

    #7342
    Britgirl
    Keymaster

    Please use this link to monitor.

    https://www.nomachine.com/TR05M05497

    You can also sign up to receive notification of when a fix has been released by checking the box ‘Notify me…’

    #7398
    puttime
    Participant

    Thanks to !Machine team for taking this up.

    Is there an update as to how long it’ll take for this fix to be rolled out?

    I don’t mind trying out a beta version also.

    Eagerly waiting for this fix.

    #7726
    mgalpin
    Participant

    I have the same issue on a Mac when connecting to a Linux system. CTRL+Tab does not work. This is a key combination that I use very often and so this significantly impacts my ability to use NoMachine.

    I’ve subscribed to the fix mentioned above. Can we ensure the fix is also applied to the Linux server? I don’t know if the problem is on the client or server side and so it could be fine as is if the problem is client side.

    I have server version 4.4.1 and player version 4.4.6.

    #7738
    Tor
    Contributor

    Hey guys.
    After going deep into this issue we’ve decided to split it up into two different problems. One is documented in TR05M05497 and it is related to Alt+Tab not working on server Windows 8 and later; the other one is about Ctrl+Tab not working correctly from OS X client:

    https://www.nomachine.com/TR07M05788

    Any of you wishing to test a fix for the latter, please contact us at forum[at]nomachine[dot]com.

    #7752
    iceback
    Participant

    I’m using 4.4.1 on mac and 4.6 on linux surver.  cmd-tab walks through mac os (local) apps, Ctrl-tab walks through linux (remote) apps.  What are you guys seeing?

     

    #7783
    Tor
    Contributor

    Iceback, the shortcut Ctrl+Tab is used to trigger the view loop, so it doesn’t go through the usual events handling and we were not catching it correctly. Maybe you’ve a different configuration or you’ve enabled the keyboard grabbing?

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.