Always connect to virtual session instead of physical desktop session

Forums / NoMachine for Linux / Always connect to virtual session instead of physical desktop session

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #37414
    anschouwe
    Participant

    Hello,

    I’ve been having a weird problem for a few days now and cannot figure it out.

    Client system: Windows 10 with NoMachine 7.8.2 (I write this post to the Linux forum because I am quite convinced that the problem is on the remote Linux side).
    Server: OpenSuSE 15.1 (KDE) with NoMachine 7.2.3 (I know it is old, but it used to work properly until a few days ago).
    I use the free versions of NoMachine.

    When I connect from my client Windows machine to the Linux server, I always end up in a virtual session, rather than connecting to the session that is running on the “physical” desktop (the one I see when I look at the monitor of the remote server).

    The process table shows (watch the second line):

    ###############################
    4 S nx       26438     1  0  80   0 - 455823 SyS_ep 09:57 ?       00:00:02 /usr/NX/bin/nxserver.bin --daemon
    0 S nx       26502 26438  0  80   0 - 333137 SyS_ep 09:57 ?       00:00:00 /usr/NX/bin/nxserver.bin<strong> --virtualsession --sessionid 145D3912DD5B....etc....</strong>
    4 S root     26605 26438  0  60 -20 - 28852 -      09:57 ?        00:00:00 /usr/NX/bin/nxexec --node --user XYZ --priority realtime --mode 0 --pid 36
    4 S XYZ  26610 26605  1  60 -20 - 828575 SyS_ep 09:57 ?       00:00:27 /usr/NX/bin/nxnode.bin
    0 S XYZ  26703 26610  0  80   0 - 360395 core_s 09:57 ?       00:00:00 /usr/NX/bin/nxclient.bin --monitor --pid 26671
    0 S nx       26871 26438  0  80   0 - 103328 -     09:57 ?        00:00:00 /usr/NX/bin/nxd
    0 S XYZ  29736     1  0  80   0 - 388044 core_s 10:19 ?       00:00:01 /usr/NX/bin/nxplayer.bin --dialog users
    0 S nx       31221 26871  3  80   0 - 381691 SyS_ep 10:28 ?       00:00:00 /usr/NX/bin/nxserver.bin -c /etc/NX/nxserver --login -H 4
    4 S root     31277 31221  0  60 -20 - 28852 -      10:28 ?        00:00:00 /usr/NX/bin/nxexec --node --user XYZ --priority realtime --mode 0 --pid 28 -H 4
    4 S XYZ  31282 31277  6  60 -20 - 581464 SyS_ep 10:28 ?       00:00:00 /usr/NX/bin/nxnode.bin -H 4
    0 S XYZ  31343 26610  2  60 -20 - 55221 -      10:28 ?        00:00:00 /usr/NX/bin/nxcodec.bin
    0 S root     31514  2726  0  80   0 -  1858 -      10:29 pts/0    00:00:00 grep --color=auto nx

    ############################

    I want to be able to login to my physical session (which is at my work place) from home. When I compare the situation with another Linux machine (where I have the same software situation), there are no processes with virtual sessions whatsoever, and I can directly log in to the physical session. This leads to the assumption that the culprit is the Linux server.

    I tend to think that there is a second graphical login session running on the Linux server, which the NoMachine client is connecting to. I wouldn’t know where this session could come from, though. I do not know how to verify this hypothesis. I have done several reboots on the Linux server inbetween, but to no avail. I even removed and installed the NoMachine rpm again, even on the client. I also tried the current 7.8.2 version on the Linux server,  all without success.

    When I login to the Linux server from a second client machine at the same time, the first client session is killed, and I get into the virtual session of the first client.

    The problem occurred a few days ago, after a somewhat mysterious reset of the Linux server in question. As far as I understand, the use of a virtual session is reserved for the pro version, but there will be others with more expertise on this in this forum.

    So, what might be wrong here? If anybody could shed some light on this, it will be greatly appreciated.

    Thank you very much,

    Pascal.

    #37469
    Britgirl
    Keymaster

    Is it possible that you were using Plasma (Xorg) before the reset of the Linux server and now that it has been “reset” it has gone back to Plasma (Wayland)?

    Disable Wayland and use x.org instead.

    1. Logout from the desktop
    2. Log in as Plasma (Xorg)
    3. Check that you can connect

    #37486
    vetrov
    Participant

    team up and find out what we use WE GET vetrov@astra210:~$ echo $XDG_SESSION_TYPE

    x11 I have Xorg. Check with yourself x11 Xorg.  Or wayland technical support will be interested since they usually write about it

    echo $XDG_SESSION_TYPE

    Attachments:
    #37510
    anschouwe
    Participant

    Hello,

    thank you for your answers.


    @Britgirl
    : I checked this, but I didn’t have a choice of either Plasma or Wayland. There was simply no menu for it. Maybe it was hidden somehow but still present in “the background” and then fell back to Wayland after this strange reset. Anyway, I took this opportunity to reinstall the whole system. It is running fine now, and I have the selection of IceWM, Plasma, Plasma (Full Wayland), Plasma (Wayland)… whatever the difference between the last two is. I suppose the first Plasma entry is Xorg Plasma, right?

    Actually, I would like not to have the choice at all, as my machines are actually machines used by my folks who do not care about accidentally selecting the wrong session type. So how do I get rid of the unwanted desktop environments?


    @vetrov
    : I do get the same “x11” as you do.

    Thank you very much again for your input!

    Cheers,

    Pascal.

    #37744
    Britgirl
    Keymaster

    I would like not to have the choice at all, as my machines are actually machines used by my folks who do not care about accidentally selecting the wrong session type. So how do I get rid of the unwanted desktop environments?

     

    You will have to do that at the system level, this is not something you set in NoMachine. For example, https://forum.kde.org/viewtopic.php?f=289&t=151924, or you can just set auto login, again at the system level. The OpenSuse user forums will be the best place to ask that question.

    #37782
    anschouwe
    Participant

    Hi Britgirl,

    that is a very useful hint, I will try it out asap.

    Regards,

    Pascal.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.