Application graphics missing

Forums / NoMachine for Linux / Application graphics missing

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4541
    Avatarsservice
    Participant

    When using NX4 with Redhat 6, when I start the application SOS from Cliosoft (version control software), the GUI starts and appears to work as expected, but no data shows up inside the applications.  If I remote into the same machine via ssh and NX3 the application works as expected.  If I log into the console and start the application it works as expected.  I’ve verified that I am using the latest client.  Has anyone else seen similar things?

     

     

    #4549
    Avatardrichard
    Participant

    @sservice       It looks to me like the theme isn’t loading quite right, so maybe it’s having a theme/font type problem.  Possibly it’s looking for a certain font and when it’s missing it’s just silently failing.  Some applications are only tested local from the system console, and need a bit of tweaking.    The technique that I use in this case is to put in a few lines of debugging information in the script that calls this application and compare NX 3 vs NX 4.   In this case I would check for fonts and for environmental variables.  So, something like:

    echo “DEBUG: fonts start here” > /tmp/nx4.log

    xlsfonts | sort >> /tmp/nx4.log

    echo “DEBUG: environmental variables here” >> /tmp/nx4.log

    env | sort >> /tmp/nx4.log

     

    Then just diff the two files.

    #4658
    AvatarBritgirl
    Keymaster

    This seems to be a very specific issue, related to an application that not many users will know, and I feel should be dealt with via the support channels (Support enquiry, or even Contact us). Let’s try to keep the forums dedicated to more “familiar problems” 🙂  i.e NoMachine issues related to applications and desktop environments shipped with Linux distros at source are fine, as most users of Linux will be familiar with those.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as closed, you can't post.