Audio disabled on local connection

Forums / NoMachine for Windows / Audio disabled on local connection

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1832
    Avatarjcdick1
    Participant

    I have a Windows client connecting to a Linux server, both running 4.0.369 … I get no audio from the server.  Checking the status by opening the menu panel, the microphone and audio are marked with a red X, and any option to change settings is greyed out.

    This is a client only installation on the Windows box.  How do I get the local client playing the audio being fed from the Linux server?

    Thanks!

    #1849
    AvatarDan25
    Participant

    Disabled audio on the server could be due to a resource list change.

    To know what it is, we will need client side logs. From the the server: nxinstall.log and node.cfg files.

    #1897
    Avatarjcdick1
    Participant

    Here are the logs you mentioned.  I just zipped the whole log directory on the client side.
    Thanks!

    Attachments:
    #1919
    AvatarBritgirl
    Keymaster

    The client side logs you attached are not complete. If you have problems attaching client and server side logs here, you can send them to forum[at]nomachine[dot]com.

    Please consult the following article for instructions on how to get the complete client and server logs:

    https://www.nomachine.com/AR10K00697

    https://www.nomachine.com/AR07K00677

     

     

     

    #1995
    Avatarjcdick1
    Participant

    Okay, I just noticed the upload error on the server side files.  I’ve put them in a zip file.  Sorry about that.

    Attachments:
    #2025
    AvatarBritgirl
    Keymaster

    And the client logs ;-) Reproduce the problem (with player opened and connected) and send us the ‘.nx’ directory.

    #2051
    Avatarjcdick1
    Participant

    Unfortunately, there doesn’t seem to be a \Program Files (x86)\NoMachine\var\log directory on my client side, at the moment.

    But here is the problem reproduced, and the .nx directory under \Users\%username%\

    #2143
    Avatarjcdick1
    Participant

    I did a full reinstall of both server and client, and still have the above, though I changed from the pure Enterprise client-only install to a full install on the client side.  No /var/log directory on the client side, and still says “Audio disabled…”

    Thanks.

    #2169
    Avatarjcdick1
    Participant

    Okay, let’s start this over, if that’s okay.  And hopefully we can get this resolved.  It used to work, now it doesn’t, as stated above.  But I just tried connecting to other machines that used to have audio forwarded successfully, and there’s no change.

    I have a windows 7 client connecting to multiple Linux servers … over a port-forwarded SSH tunnel.  UDP is not being used.  My client has “Audio disabled on local connection” no matter which machine I talk to.  Does the client automatically disable audio when the address for the server is “localhost”?

     

    Thanks.

    #2176
    AvatarBritgirl
    Keymaster

    Hi, we appreciate your patience. It’s a bug, so we’re going to open a Trouble Report.

    #2441
    Avatarjcdick1
    Participant

    I just wanted to check back on this, as I’ve had to resort to Splashtop, which I’m not keen on.  Is there any estimate on which update cycle this might be in?

    Thanks!

    #3038
    AvatarBritgirl
    Keymaster

    @jckdick1 – Come and download the latest packages to get the fix for this bug https://www.nomachine.com/TR02L04256. It’s now closed.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.