Audio from remote Windows to Linux client not working

Forums / NoMachine for Windows / Audio from remote Windows to Linux client not working

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #36485
    bfenty
    Participant

    I am able to get the microphone to work transmitting TO the Windows remote, but the speaker/audio output from the Windows remote is not coming through on the Linux client. When I connect, the default speakers show muted on the remote machine. If I unmute them, they come through the remote machine’s speakers. I am unclear if there is an additional step to enable audio? I have turned it on in the NoMachine control panel.

    #36521
    tsotne
    Participant

    Hi,
    NoMachine reads audio stream from default audio device on server side and transmits it to client.

    You can mute or not server side audio choosing setting while you are connecting to server machine. By default it asks about it and if you agree it mutes physical audio on server side.

    As I get audio on windows is working fine, but does audio work on client side correctly?
    Please check also if your default sound output device is running in the exclusive mode and try to disable it.

    https://answers.microsoft.com/en-us/windows/forum/all/disable-exclusion-mode-windows-audio-driver/92c92324-f189-4ae4-ba14-7c5dda7e6183

    #36528
    bfenty
    Participant

    It looks like the issue that I was running into was that it was switching audio outputs when I connected to a THX output instead of the default speakers. Switching back after the initial connection didn’t fix it. Disabling the THX output fixed the issue.

    Now I am having an issue with the mic audio input quality being very poor. My output audio sounds perfect without lag-I’m not sure why input/mic would be so terrible.

    #36535
    tsotne
    Participant

    Where (in which application) and how do you use forwarded mic?
    It could be a problem with the app itself.

    1. Check if it is not mic issue, try to test in different machine and so on (if you use external mic, but if you use built-in one, try to test it also in some audio recording apps).

    2. Connect to Windows server using NoMachine and forward the mic.

    3. Try opening some Windows recording tools (there are different methods, here is one way)
    https://www.windowscentral.com/how-record-sound-using-voice-recorder-app-windows-10

    4. Record audio (by default it should use default mic, which after forwarding mic in NoMachine session is NoMachine mic adapter, but if it is not set to it set it correctly in app).

    5. Play back to see if it has some dropouts.

    6. go to https://online-voice-recorder.com/

    7. record audio and listen to check if there are some dropouts.

    8. If you didn’t get any dropouts then it’s not NoMachine’s fault.

    9. If  you still get that weird behavior, check and monitor network connections on server as on client, it could be network issue.

    10. Also audio is CPU consuming and check if there are some heavy cpu-consumption tasks are running both sides.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.