Audio from server to Android client

Forums / NoMachine for Linux / Audio from server to Android client

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #13934
    eunosNB
    Participant

    I am using NoMachine to connect remotely to my home server (ubuntu 16.04.x w/ lubuntu as DE) from my Android tablet. It works quite well.  However, I have not been able to figure out how to forward audio from the server to my tablet. I have “Enable Streaming” checked on the android app, and I have pulseaudio installed (and running) on the server. Still, no sound comes through.

    So, what do I need to post for a proper troubleshooting?  Logs?  Config file details?

    TIA,

    eunosNB

    #13943
    kroy
    Contributor

    We couldn’t reproduce such problem. Can you write which NoMachine versions do you use on both sides? Please write also what is the device and Android version.

    #13954
    eunosNB
    Participant

    I am using a Samsung Galaxy Tab Pro with the latest app version 5.0.63 on Android 4.4.2.  The server has nx version 5.1.62 on it.  I haven’t upgraded to 5.2.11 because I don’t want to break my (mostly) working setup.

    #13967
    kroy
    Contributor

    Are you able to verify from which side problem comes? If you try to connect from other device to the server – audio works? And if you connect from tablet to other server you can hear sound?

    I haven’t upgraded to 5.2.11 because I don’t want to break my (mostly) working setup.

    Did you mean NoMachine setup? During update configuration files are saved so you will keep your settings.

    #13983
    eunosNB
    Participant

    I do not have any other machines to use for testing.  When I asked my question, I figured I simply had a config file that needed updated.  I can test on a laptop into the server if I add NM to the laptop.  However, I only have the one server, so I cannot connect from my tablet to some other NM server.

    As for the updated software, I have a general aversion to upgrading unless I also have time to debug and fix whatever the upgrade might break.  It is not worth it to me to risk the problems an update might create.

    #14142
    eunosNB
    Participant

    Is this thing on?

    #14156
    Britgirl
    Keymaster

    Sorry for the late  reply. As a rule we test problems that users are reporting on both the version they are using and also the most recent version released if there has been a software update in the meantime. We haven’t been able to reproduce on either. So what you should do is submit logs:

    Do the following:

    – please disable autocleaning of logs in the /usr/NX/etc/node.cfg by setting ‘SessionLogClean 0’

    – restart the nxserver

    – reproduce the problem with audio and then gather up the logs: sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log

    Send them to forum[at]nomachine[dot]com

Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.