Audio only when remote miniPC audio enabled

Forums / NoMachine for Windows / Audio only when remote miniPC audio enabled

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #38029
    cytan299
    Participant

    Hi,

    I have NoMachine installed on my remote miniPC running Win11 (this problem was also there in Win10) and control it with my MacBookPro. The weird thing is that there is no audio streamed from the miniPC to the MacBookPro unless the miniPC is disabled.

    Is there some setting that I need to enable/disable to get streaming from the miniPC to MacBookPro to work without enabling the audio on my miniPC. Screenshots are attached.

    Some details of my setup:

    miniPC running win11 running NoMachine 7.9.2

    MacBookPro running BigSur, NoMachine 7.9.2

     

    Thanks

    cytan

     

     

    #38043
    cytan299
    Participant

    Sorry, I meant “ The weird thing is that there is no audio streamed from the miniPC to the MacBookPro unless the miniPC *audio is ENABLED*”

    Any help appreciated. Thanks!

    cytan

    #38044
    Britgirl
    Keymaster

    Audio has to be enabled on the system you are connecting to (miniPC) and then from the connection menu you mute the sound on the server which appears to be what you did. Does this not mute audio on the server?

    #38047
    cytan299
    Participant

    Hi Britgirl

    I’m not sure which is server or client in the NoMachine world. In order to have sound streamed from the MiniPC to my MacBook Pro, I have to *unmute* sound on my MiniPC (as indicated in the jpg above).

    When the MiniPC audio is unmuted it plays through its speakers and streams to my MacBook Pro. When sound is muted on the MiniPC as shown in the jpg, there’s no sound streamed from the MiniPC to my MacBook Pro and it is muted at the MiniPC as well. I believe this is not working the way NoMachine audio streaming is supposed to work.

     

    cytan

    #38054
    Britgirl
    Keymaster

    Server in NoMachine jargon is always the computer you are connecting to 🙂 We’re checking now that we have the additional information, and I will update the topic when I get feedback from the test team.

    #38055
    cytan299
    Participant

    Hi Britgirl,

    Just another data point to consider: I have another PC that has RealTek sound hardware and that works with the audio muted at the PC end.

    My miniPC has an Intel SmartSound hardware, so perhaps that’s the problem.

     

    cytan

    #38065
    kubaszym1
    Participant

    Hi,

    There is a way you can temporarily fix it. Our test team found that setting NoMachine Microphone Adapter as the default device fixes the issue but it shouldn’t work that way. Microphone adapter is for sending voice from the client to the server. We’re now trying to investigate why this happens on Windows.

    #38067
    cytan299
    Participant

    Hi kubaszym,

    I tried your suggestion this morning and unfortunately, streaming sound to my MacBook Pro doesn’t work at all with the selection of the NoMachine Microphone adapter. Please see attached screen shot.

    When you do your fix, please note that my laptop with the RealTek sound chipset streams fine to my MacBook Pro with the audio muted on the laptop.

     

    cytan

    Attachments:
    #38226
    kubaszym1
    Participant

    Hi,

    You can try to workaround this issue by plugging in an external device, i.e. headphones to your Windows machine. Then connect to the Windows machine via NoMachine and check if everything works as expected. I hope it will help you. I’m still trying to find out why capturing audio doesn’t work with several drivers.

    #38233
    cytan299
    Participant

    Hi kubaszym1,

    Yes, I’ve already done this. I’ve plugged in an audio plug to mute the sound at the miniPC (pink plug in the photo) and then unmuting the sound on the miniPC. This means that I can stream the audio from the miniPC to my MacBook Pro without audio spilling out from the miniPC.

    I’m eagerly waiting for your fix.

     

    cytan

    #38249
    kubaszym1
    Participant

    Hi,

    Unfortunately there’s nothing more I can do. I found out it depends on the functionalities that your audio driver supports. There is a small chance that updating drivers might help you, but it’s not for sure.

    #38253
    cytan299
    Participant

    Hi kubasym1,

    Thanks for trying to fix the problem and confirming that it was a driver problem like I had suspected.

    As for updating drivers, that was my first thought as well. I have the latest Intel driver for the audio chip, so that isn’t a solution.

    The workaround with an audio plug inserted into the audio port is acceptable for me.

    Thanks again.

    cytan

    P.S. If you do find a solution, or some other way to stream audio with the audio muted at the server, please post in this thread so I can test it out. Thanks.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.