Audio streaming and microphone forwarding

Forums / NoMachine for Windows / Audio streaming and microphone forwarding

  • This topic has 3 replies, 3 voices, and was last updated 1 week ago by Avatarmkub.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #26234
    Avatarleorke
    Participant

    I have an ham radio attached to a nomachine server running Windows 10  and would like to control it from remotely.

    From a remote client I can work all digital modes, but I’m not able to hear audio on the client neither forward the microphone to the radio attached to the server.

    Looking for help on how to use the audiointerface nxaudio (that is enabled).

    #26290
    Avatarmkub
    Participant

    Hi,

    Are you able to hear the radio on the remote machine, physically? NoMachine connects to the default output and input of the machine. There is no option to customize it. You can try to set your radio as a default audio device before establishing the session. Then, when you connect to the machine, radio will be your sink and source. Please remember to enable microphone during session.

    #26312
    Avatarleorke
    Participant

    Hi,

    thanks a lot for your reply. The radio is connected to the NoMachine server through a built-in sound card used to source the audio to be processed in DSP and to sink the audio to transmitted.¬† I can’t hear the radio through the server locally and physically. I don’t know how to pass the audio from the built-in card in the radio to the sound card of the server.

    Moreover I have also a server made with raspberry Rpi4 that is working thanks to PulseAudio and Pavucontrol and a script to redirect the audio to a dummy , but here the problem is that the streaming  is not reliable. Some times it works some other not.

    This is why I have opted for a Windows 10 server.

    #26325
    Avatarmkub
    Participant

    Hi,

    Check if the NoMachine audio input and output work properly. If so, try to direct the sound from the audio devices to your radio.

    Thanks, mkub

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.