Authentication failed (key-based auth)

Forums / NoMachine for Linux / Authentication failed (key-based auth)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #36495
    dead_drops
    Participant

    Hello,

    I’ve recently set up NoMachine for an RDP between my laptop (Ubuntu) and home machine (Arch), using a password authentication. I want to be more secure and instead set up the key-based authentication, so I followed this article (https://knowledgebase.nomachine.com/AR02L00785) to do so. I’ve generated an ssh key on my laptop and added the public key to ~.nx/config/authorized.crt, and used chmod to give 0600 permissions to the file. I then added my laptops private key to the key-based authentication configuration and passed my username and no passphrase, because I didn’t set one, and when I attempt to connect I get “Authentication failed, please try again.”

    What I’ve tried:

    restarting the nxserver.service on both machines
    re-tracing my steps from the article
    ssh user@ip (from laptop to desktop), which works

    Lastly, ssh -i @ -vvv (from laptop to desktop) this was suggested in the most recent forum post I could find on this issue. This doesn’t work, I’m not sure why, given I only have one key-pair on my laptop, and ssh-keygen -y -f ~.ssh/id_rsa > test.pub yields the same public key as my ~.ssh/id_rsa.pubfile, which is what is in my ~.nx/config/authorized.crt on my desktop. I really don’t know what is going on with this, probably just a lack of understanding on my part.

    If anyone would like to see any other logs, let me know. Any help on this is much appreciated!

    #36498
    Britgirl
    Keymaster

    Hi, the attachments didn’t attach correctly. Could you send them direct so I can attach them separately? 🙂 Just send them to forum[at]nomachine[dot]com and use the topic title as the subject. Thanks!

    #36572
    Britgirl
    Keymaster

    Hi, the attachments weren’t very helpful. Nevermind 🙂

    Anyway, the issue you are experiencing shows when the private key (the one you are loading to the Player) is not recognized. Are you able to send us this key (privately, not here) so we can take a look? If you prefer, you could generate a test key and reproduce the same identical problem, then send this key to us. Attachments can be sent to forum[at]nomachine[dot]com.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.