Authentication request to change options using LDAP login

Forums / NoMachine for Linux / Authentication request to change options using LDAP login

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #21805
    Gaet16221284
    Participant

    Hello,

    I recently installed NoMachine on an Ubuntu 18.04 LTS machine in an LDAP domain (Freeipa).

    When I want to change an option on the server or quit the program, a dialog box asks me for an administrator password.

    I tried to use the user account or root account, but it doesn’t work.

    My LDAP login is an administrator account without any restrictions.

    Can NoMachine be operated in an LDAP environment?

    Regards

    #21829
    graywolf
    Moderator

    Hello. Would you tell me if users’ home folders are remotely mounted by NFS? That could be related because settings panel could get troubles retrieving confi files.

    #21840
    Gaet16221284
    Participant

    Hi,

    User data is local. The LDAP implementation being new we are not there yet 🙂

    Regards

    #21900
    graywolf
    Moderator

    Would you paste the output of command:

    sudo -l -U <username>

    and upload the content of $HOME/.nx folder?

    #21919
    Gaet16221284
    Participant

    Hello,

    Output of sudo -l -U

    env_reset, mail_badpass, secure_path=/usr/local/sbin\:/usr/local/bin\:/usr/sbin\:/usr/bin\:/sbin\:/bin\:/snap/bin

    (ALL : ALL) !/usr/bin/apt-mark
    (ALL : ALL) !/usr/bin/passwd
    (ALL : ALL) NOPASSWD: ALL

    The contents of the.nx file are attached.

     

    Regards

    Attachments:
    #21960
    Britgirl
    Keymaster

    @Gaet16221284 we’d like to send you a small debug library to let us get further debug information for the investigation. If you agree, we’ll send it on privately with further instructions. Thanks!

    #21996
    Gaet16221284
    Participant

    Hello,

    We can do it this way.

     

     

    #22008
    Gaet16221284
    Participant

    Hi,

    I sent back the requested information by email.

    Regards

     

    #22015
    graywolf
    Moderator

    Would you temporary modify the “sudo” setting in order to be asked for password?

    #22018
    Gaet16221284
    Participant

    Hi,

    What rights should be added?

    I have the same problem with sudo./nxserver –startup
    NoMachine asks me for administrator IDs but none are accepted.

     

    Regards

    #22022
    graywolf
    Moderator

    Try to run “visudo” and remove the word NOPASSWD from the active line (no heading #) where you see:
    (ALL : ALL) NOPASSWD: ALL

    #22128
    Gaet16221284
    Participant

    Hi,

    I had contact with the support and they provided me with a modified executable.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.