Automatic NAT Configuration — Why?

Forums / General Discussions / Automatic NAT Configuration — Why?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #24985
    Avatardhsto
    Participant

    I was looking around in my router config and under “NAT — Virtual Servers Setup” it has the following information:

    Server Name External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address WAN Interface
    NoMachine 23960 23960 TCP 4000 4000 192.168.1.10 ppp1.1
    NoMachine 24160 24160 TCP 4000 4000 192.168.1.125 ppp1.1
    NoMachine 4271 4271 UDP 4271 4271 192.168.1.10 ppp1.1

    If I remove these entries they will automatically be repopulated within a few minutes after launching NoMachine. 192.168.1.10 is the computer I’m connecting from and 192.168.1.125 is the computer I’m connecting to.

    So why does this happen and doesn’t this configuration mean that it’s directing these public ports to internal ports in my local network?

    I really like NoMachine, but I’ve uninstalled it because this happens. Perhaps this is something my router does to try to be helpful? I’m guessing NoMachine must do something to trigger that originally though.

    Maybe there’s a setting I can disable to stop this from happening? My router is a SmartRG SR515ac.

    Thanks in advance!

    #25002
    AvatarBilbotine
    Keymaster

    Hi dhsto,

    Please try to set the EnableUPnP key in /usr/NX/etc/server.cfg from EnableUPnP to none, and let us know if that helps!

    Note that UPnP or NAT-PMP is required for automatic port-mapping. Without UPnp, it will be necessary to configure the router manually and open the requested port.

     

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.