AVC Pack for Windows doesn’t seem to work?

Forums / NoMachine for Windows / AVC Pack for Windows doesn’t seem to work?

Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #16877
    BrotherO4Him
    Participant

    Hi,

    The original topic was closed to I’m posting this here. I was able to resolve my issue. After rounds of uninstalling and reinstalling the client and avc pack and experimenting with the configuration option I discovered that enabling and configuring the “Use a specific display encoding” under the Performance tab in the Server preferences to H.264, even with the AVC pack installed correctly, it seemed to be ignored and the connection would revert to VP8. Leaving this setting unconfigured as default, the AVC pack works as expected and the connections are encoded in H.264. I am not sure if this a bug or by design or what.

    I hope this helps someone else that may be having this issue. Since the original post I have updated to the 6.x release and the behavior is as described above.

    #16882
    Britgirl
    Keymaster
    #16890
    Britgirl
    Keymaster

    We aren’t able to reproduce this behaviour. If you have the AVC pack available, you shouldn’t need to change anything in the server-side settings (or client, for that matter). NoMachine by default checks first if H.264 is available, if it isn’t available, it falls back to VP8. The settings are there for additional configuration when you want to force a specific codec, frame-rate and so forth. Did you do a restart of NoMachine?

    #16910
    BrotherO4Him
    Participant

    I did do a restart. The PC that is acting as the server has an Intel processor with the Quicksync disabled (on the CPU or by the driver i’m not sure). I’ve observed that installing the avc pack and forcing the codec to H.264 in the preferences caused it to fallback to VP8. I don’t know why the behavior is not reproducible for you. In any case, It works now when I leave the settings alone after installing and i’m happy with it.

    #16934
    Britgirl
    Keymaster

    It’s very strange. If you send in your node.cfg we can check it to see that there’s no weird setting.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.