Avoid user prompt when authenticating through private key

Forums / NoMachine for Linux / Avoid user prompt when authenticating through private key

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #17597
    sebaneo
    Participant

    Hello, I have a question. I’m trying to authenticate using private key method. The authentication is working correctly but nxplayer always ask to me the username. I need to access without this prompt. Is there a way or somewhere in the settings to do this whithout the prompt?

    For example, i need to execute this line “/usr/NX/bin/nxplayer –session session.nxs –config player.cfg” and connect to the user desktop in a not interactive mode.

    I attach the user prompt screen

    Thank you

    #17616
    kroy
    Contributor

    There is a trouble report open for this bug: https://www.nomachine.com/TR12N07463 . Please use the notify me tool to know when a fix is available.

    It’s possible to find a temporary workaround for your case. You can generate new key with passphrase (or add passphrase to old key) and save it in nxplayer or just edit session.nxs file (in the default is in ~/Documents/NoMachine directory) and change line:

    <option key="Remember password" value="false" />

    to:

    <option key="Remember password" value="true" />

    #17624
    sebaneo
    Participant

    Thank you, I’ll try this┬ásolution

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as closed, you can't post.