Behavior of NX Server 3.5 doesn’t work in NX 4

Forums / NoMachine Cloud Server Products / Behavior of NX Server 3.5 doesn’t work in NX 4

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1361
    Avatarsnejok
    Participant

    Hello, Dear NoMachine!

    I try to restore behavior of NX Server 3.5 in nomachine-enterprise-server-evaluation_4.0.369_2_i386.deb by https://www.nomachine.com/AR07K00681, but it’s doesn’t work: always creates new virtual desktop instead of reconnection to suspended session.

    Server and Client OS: ubuntu-12.04-server-i386.iso

    Client version: nomachine-enterprise-client_4.0.369_1_i386.deb

    I launch client by this command: /usr/NX/bin/nxplayer /home/user/NoMachine/Unnamed\ connection\ 1.nxs

    Server configs+logs, “dpkg -l from server and client” and “Unnamed connection 1.nxs” attached

    #1437
    Avatarsil04
    Keymaster

    Did you try to set:

    ConnectPolicy autocreate=0,autoconnect=1,desktop=0

    in the server configuration?

     

    Be also sure that the first time you connect, you check ‘Save this setting in the configuration file’ in the GUI.  Then disconnect and connect once again: you should now be able to reconnect the virtual desktop.

    #1445
    Avatarsnejok
    Participant

    I tried it again and result is:

    1. NXPlayer doesn’t show me all the desktop types available on that server”, but connects me after I click on  ‘Create a new virtual desktop’, but in https://www.nomachine.com/AR07K00681 wrote:

    On the server side:
    ConnectPolicy autocreate=0,autoconnect=1,desktop=0
    On the player side, you will need to follow the same steps as above:

    – When you connect for the first time to that server: Open NoMachine -> Click Add a computer -> Fill in IP and session name -> Connect -> Click on  ‘Create a new virtual desktop’.

    In the next panel showing all the desktop types available on that server, check ‘Save this setting in the configuration file’.

    Choose and create the desktop you want to connect.

    – Disconnect the session by closing the window or disconnecting from the menu (ctrl-alt-0 ->

    – Launch this connection again: you should be re-connected automatically to the virtual desktop you have created the first time.

    Bolded options doesn’t show

     

    2. Reconnection doesn’t work automatically: nxplayer shows me the running sessions (see screenshot)

     

    Be also sure that the first time you connect, you check ‘Save this setting in the configuration file’ in the GUI.  Then disconnect and connect once again: you should now be able to reconnect the virtual desktop.

    I’m really sure

     

     

    Attachments:
    #1463
    Avatarreza
    Moderator

    Please assure that in server.cfg key ConnectPolicy desktop is set to 0.

    When crating a new session, instead of selecting ‘Create a new custom session’ try  ‘Create a new Ubuntu virtual desktop’.

    You can customize this session type with node.cfg key DefaultDesktopCommand.

    • This reply was modified 6 years, 11 months ago by Avatarreza.
    #1490
    AvatarTor
    Contributor

    – In the next panel showing all the desktop types available on that server, check ‘Save this setting in the configuration file’.

    – Choose and create the desktop you want to connect.

    [snip]

     

    Your server may have only one virtual desktop type available, so the client automatically selects it and doesn’t give the possibility to save the preference. A more correct way to configure the connection consists in clicking the ‘New virtual desktop or custom session’ button. We’ve changed the article accordingly.

    2. Reconnection doesn’t work automatically: nxplayer shows me the running sessions (see screenshot)

    Trouble Report describing the issue is here: https://www.nomachine.com/TR12K04170

    #1683
    Avatarsnejok
    Participant

    Hello, Tor!

    I set “ConnectPolicy autocreate=1,autoconnect=1,desktop=0” in server.cfg and after that I can see “Create a new virtual desktop” near “Create a new custom session”.

    With “Create a new virtual desktop” reconnection works fine (in single-node mode)! Thank you!

    But, reconnection fails, when I set multi-node environment (new virtual sessions starts on another node).

    I will give more info and logs when I reproduce this behavior on clean VM’s 🙂

    #1853
    Avatarsnejok
    Participant

    Hello, all!

    Server and Node OS: ubuntu-12.04-server-i386.iso

    Client OS: ALT Linux 6.0

    Server: nomachine-enterprise-server-evaluation_4.0.369_2_i386.deb (ip – 10.10.19.152)

    Node: nomachine-terminal-server-node-evaluation_4.0.369_1_i386.deb (ip – 10.10.19.189)

    Client: nomachine-enterprise-client_4.0.369_1_i686.rpm (ip – 10.10.19.50)

     

    Reconnection works only to session, that started on “server node”, reconnection to session, that started on “node” doesn’t work (new session starts again on “server node” by round-robin algorithm).

     

    And small question:

    root@ubuntu:~# /usr/NX/bin/nxserver –nodelist

    NX> 104 Node list:

    NX> 104 .

    Status      Connection  Node                           Type    LB  Weight  Limit  Label

    ———– ———– —————————— ——- — ——- —– ———————

    running     encrypted   10.10.19.189:4000              NX      yes

    running     encrypted   localhost:22                   NX      yes

     

    root@ubuntu:~#

    why “out of the box server node” comes with port 22 (proto SSH?), but when I run “nxserver –nodeadd <ip>” its added with port 4000 (proto NX?)?

    #2065
    AvatarBritgirl
    Keymaster

    There is an issue with reporting sessions from remote node where NoMachine server did not find working ‘X server’. That’s why the virtual
    session was indeed created on the remote host, but it was not reported on ‘session list’. Thus the session will not be available for reconnection. Version 4.1 will have the fix.

    why “out of the box server node” comes with port 22 (proto SSH?), but when I run “nxserver –nodeadd <ip>” its added with port 4000 (proto NX?)?

    https://www.nomachine.com/TR01L04245

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.