Black screen after install

Forums / NoMachine for Linux / Black screen after install

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1312
    Avatarspecter
    Participant

    Ubuntu 12.04.3 LTS (Clean install from today, updates installed)

    nomachine_4.0.369_1_amd64.deb

    1. Install nomachine_4.0.369_1_amd64.deb

    2. Reboot machine

    3. Get black screen with blinking cursor

    4. sudo apt-get remove nomachine

    5. Reboot machine

    6. Boots normally to login screen

    Anyone else see this behaviour? Was working fine with earlier builds of version 4.

    #1323
    Avatarfra81
    Moderator

    We are not able to reproduce this behaviour.

    Can you send us the client and server logs? Submit to issues[at]nomachine.com referencing the topic title in your subject.

    Logs can be extracted using the instructions here:

    https://www.nomachine.com/AR10K00697

    #1331
    Avatarreza
    Moderator

    Please,

    Reinstall the package as usual and then disable the server:

    # update-rc.d nxserver disable

    Try to reboot and see if the login screen comes up.

    After that, re-enable the server:

    # update-rc.d nxserver enable

    # /etc/NX/nxserver –startup

    See if you can connect.

    Disable all services by editing /usr/NX/etc/node.cfg and setting:

    EnableDiskSharing key to ‘none’

    EnablePrinterSharing key to ‘none’

    EnableUSBSharing key to ‘none’

    EnableNetworkSharing key to ‘none’

    EnableSmartcardSharing key to ‘no’

    But not disable the NX service.

    Reboot.

    See if without the services the login screen comes up.

    Stop at any failed step and please send the logs.

    • This reply was modified 7 years, 1 month ago by Avatarreza.
Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.