Black screen after updating a few days go

Forums / NoMachine for Windows / Black screen after updating a few days go

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11937
    cacophony555
    Participant

    I am running the free versions of NoMachine on my remote Ubuntu 12.04 PC (with Gnome) and my local Windows 7 PC for the last year or so with no issues. The remote machine has dual monitors and I’m using the NX protocol to connect.

    A few days ago I was physically using the remote Ubuntu machine and NoMachine popped up a window saying it needed to update. So I let it update. Later that night when I tried to connect from my Windows 7 PC it seemed to connect, but I was just presented with a black screen. Normally the screen starts out black but when I move the mouse I get a login prompt but that didn’t work. I tried switching to the other display via ALT-2 and but it was also black.

    So I tried manually updating NoMachine on my Windows 7 PC. That didn’t help.

    The next day or so I got another NoMachine update window while physically using my remote Ubuntu box. I let it up update again hoping that it would fix the issue. But alas when I got home it still has the same problem.

    I saw another thread which mentioned disabling acceleration for display processing, which I tried on my Windows 7 PC but it didn’t help.

    At this point I’m tempted to try a complete re-installation on both the client and server, but before I go there any ideas?

    #11940
    kroy
    Contributor

    Can you check value key PhysicalDesktopMode in server configuration file?

    cat /usr/NX/etc/server.cfg |grep PhysicalDesktopMode

    If there is 0 – you cannot interact with the physical desktop because it’s view-only-mode. The following fix was introduced to fix this broken key: https://www.nomachine.com/TR03N06661.

    If you don’t have enabled view-only-mode please run debug, reproduce issue and send all logs from server and client side to forum[at]nomachine[dot]com or attach them here (size is restricted). Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT04M00076.

    #11945
    cacophony555
    Participant

    So the cat reveals:

    cat /usr/NX/etc/server.cfg |grep PhysicalDesktopMode
    PhysicalDesktopMode 0

    Should I edit the file and change it to a “1” or “2”? The file is currently read only but I could force it… Then do I need to restart NoMachine on my server? If so it’s not obvious how to do that.

    Thanks for the help!

    #11946
    cacophony555
    Participant

    FYI, changing the PhysicalDesktopMode value fixed the issue for me.

    Thanks for the help!

    #11956
    Britgirl
    Keymaster

    Restart isn’t necessary 😉 Sorry if that wasn’t specified, but glad to hear the issue is now fixed.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.