Black screen connecting to physical display

Forums / NoMachine for Linux / Black screen connecting to physical display

This topic contains 13 replies, has 3 voices, and was last updated by Avatar Britgirl 17 minutes ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #23455
    Avatar
    rcasero
    Participant

    Trying to connect to the physical display of a desktop from a laptop.

    • NoMachine Workstation installed on both machines with nomachine-workstation_6.7.6_11_amd64.deb.
    • Ubuntu 19.04 with GNOME on both client and server.

    On the server, connections have been allowed with

    sudo ufw allow 4000/tcp

    sudo ufw allow 4701/udp

    User that is going to connect has been added as trusted user on the server side.

    Security preferences on the server are all (Require permission to let remove users connect, etc) disabled except for “Use sound notifications when there is an event”.

    Client configured to connect with protocol NX to the server’s IP address on port 4000.

    Doble-click on the connection icon (called “Ramon’s MRC Desktop) briefly shows “Connection to Ramon’s MRC Desktop”, and then a sessions screen with an Ubuntu session icon and the caption “Physical display, gdm, Ubuntu X server on :1001 <user icon> 0”.

    Double-click on the latter shows the “Menu panel” screen, where “Display the menu panel covering all screen” is selected.

    Clicking OK leads to a black screen. The mouse moves on the client side, but nothing happens on the NoMachine’s screen when moving the mouse or pressing keys.

     

    #23458
    Avatar
    rcasero
    Participant

    Logs have been sent by email to as described in https://www.nomachine.com/DT10O00163

    #23460
    Avatar
    rcasero
    Participant

    Another detail that may be relevant, I’m using the Nvidia driver nvidia-driver-418 on both desktop and laptop.

    #23587
    Avatar
    Britgirl
    Keymaster

    Hi, we received the logs, thank you. Unfortunately, we also need the logs from nxserver –daemon. So, it’s best to restart the nxserver, reproduce the problem again and resubmit logs. Thanks!

    #23594
    Avatar
    rcasero
    Participant

    Hi, isn’t that the NoMachine-log.tar.gz file that I already sent to you?

    That should correspond to “1. How to Collect Server Side Logs” -> “1.1. Server on Linux”

    #23595
    Avatar
    rcasero
    Participant

    PS. On a related issue, Britgirl, although I checked “Notify me of follow-up replies via email”, I haven’t received an email notification for your reply (I checked my spam folder too).

    #23600
    Avatar
    Britgirl
    Keymaster

    The logs you submitted did not include the nxserver –daemon parts, for whatever reason, and it is these that we need, so what you should do is restart the server and proceed with extracting a new set of logs as per  https://www.nomachine.com/DT10O00163. Thanks very much.

    “Notify me of follow-up replies via email”,

    The box wasn’t checked. Confirm that you are now receiving email notifications, please.

    #23605
    Avatar
    rcasero
    Participant

    OK, I’ll extract a new set of logs when I get home.

    Not receiving email notifications for your replies yet (I only get emails for the ones I write myself). I’m positive that the tick box for “Notify me on follow-up replies via email” was ticked. Like in this reply I’m writing right now. The box is in front of my eyes, and it’s ticked.

    #23607
    Avatar
    Britgirl
    Keymaster

    Not receiving email notifications for your replies yet (I only get emails for the ones I write myself). I’m positive that the tick box for “Notify me on follow-up replies via email” was ticked. Like in this reply I’m writing right now. The box is in front of my eyes, and it’s ticked.

    I’ll get this investigated. Send the logs to forum[at]nomachine[dot]com at your earliest convenience.

    #23626
    Avatar
    rcasero
    Participant

    Hi Britgirl,

    I’ve emailed the logs again, as requested.

    Just to confirm, I didn’t get an email notification for your last post either, September 12, 2019 at 15:28

     

    #23631
    Avatar
    Britgirl
    Keymaster

    Hi, logs received.

     

    I didn’t get an email notification for your last post either, September 12

    Thanks for letting us know.

    #23635
    Avatar
    Mth
    Contributor

    Hello.

    After analyzing the logs it seems that we have a problem with detecting physical session
    on Ubuntu 19.04 that has eluded us until now. We will hopefully have it fixed soon.

    In the meantime please try a workaround:

    1. Please edit the server.cfg file located by default in ‘/usr/NX/etc/server.cfg’. Uncomment and edit
    the key PhysicalDisplays, so it looks like:

    PhysicalDisplays :0-:1200

    2. Please edit the node.cfg file located by default in ‘/usr/NX/etc/node.cfg’. Uncomment and edit
    the key DisplayBase, so it looks like:

    DisplayBase :1201

    3. Restart the nxserver service:

    # /etc/NX/nxserver --restart

    Please let us know if this worked for you.

    /Mth

    #23642
    Avatar
    rcasero
    Participant

    Hi /Mth,

    Thanks for the proposed workaround, but it didn’t work. I still get a black screen, and moving the mouse, clicking or typing doesn’t do anything.

    In more detail: I edited the files on the server side, as requested. The option PhysicalDisplays didn’t exist in file ‘/usr/NX/etc/server.cfg’, so I added the suggested line to the end of the file. Same thing with DisplayBase in /usr/NX/etc/node.cfg’. I restarted nxserver as requested. Then I tried to connect with the client.

    I have emailed the logs again.

    On a related note, I’m still not receiving email notification from your replies.

    Kind regards,

    Ramon.

    #23644
    Avatar
    Britgirl
    Keymaster

    we got the logs, thank you. We also investigated the notification bug and it is now fixed.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.