Black screen on Linux Mint laptop

Forums / NoMachine for Linux / Black screen on Linux Mint laptop

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #33201
    Avatarjunkhar
    Participant

    I have a Linux Mint physical remote machine which my Linux Mint desktop can remote into without issue.

    My Linux Mint laptop is getting the black screen when it remotes in. All of them are on the free NoMachine 7.4.1. The laptop was working until a week or so ago.

    In addition, I have two monitors attached to the laptop and the Nvidia card is active.

    The xorg.conf does have this in it which seems to mean it is running headless.

    Section “Screen”
    Identifier “nvidia”
    Device “nvidia”
    Option “AllowEmptyInitialConfiguration”
    EndSection

    #33221
    Avataramigabill
    Participant

    I have a similar problem. Using local Windows 10 64bit Pro laptop, connecting to remote (on LAN) Kubuntu 20.04.2 LTS.

    My problem is intermittent. If the remote Linux server has recently been rebooted, then it works. If it’s been a while, then I get the login screen OK, but after successful login, I get only a black screen with a mouse pointer. If I then use ssh to login and reboot the remote server, then NM most likely works again fully including a working KDE desktop after login.

    I have found many questions of exactly my problem, but not yet any solution in any of those numerous threads across the internet.

    Windows is running NM 7.4.1, Linux is running 7.2.3, and both claim to be up to date.

    This happens to me frequently, and sometimes it’s not inconvenient to reboot, but sometimes it is, and seems like I should not need to most times I connect to this thing.

    Linux is not headless, as seems asked in some other threads. It has a 4k monitor on it. But it’s downstairs in the basement, and sometimes I am not. And I always get the server’s Ubuntu login screen, even when the black screen problem follows that. I have two users, and it happens when logging into either of those logins. There is not a “working one” and a “broken one”, all logins are “broken”.

    How do I create what data you need?

     

     

    #33231
    Avatarjunkhar
    Participant

    This makes even less sense. The LM 20.1 laptop which is getting the black screen can remote into the Windows computer which I’m using as a backup. So it appears to be that one laptop can’t remote into one computer. Talk about annoyingly intermittent.

    #33230
    Avatarjunkhar
    Participant

    I have tested on multiple computers now it’s only the one laptop running LM 20.1 which has a problem. I’m certain it isn’t a server issue but instead a problem with the laptop I’m using to remote with. Desktop with LM 20.1 works fine as does Windows computers.

    The laptop is headless and I’m checking on other forums for ensuring some of the other states. I am locked into Nvidia performance mode and even with multiple monitors in use NoMachine window is black when I remote.

    #33309
    AvatarCarin
    Participant

    @junkhar, you may take a look at this article How to solve black screen and other possible problems on headless machines


    @amigabill
    , in order to further investigate the issue can you please collect and send us server-side logs? You can follow the instructions explained in this article: https://knowledgebase.nomachine.com/DT11R00181#1.1. Please submit them to forum[at]nomachine[dot]com adding the title of the topic as the email subject. Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.