Black screen or session negotiation failed

Forums / NoMachine for Linux / Black screen or session negotiation failed

This topic contains 1 reply, has 2 voices, and was last updated by Avatar og00r 3 weeks, 4 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #24122
    Avatar
    kttn8769
    Participant

    Hi,

    I’m trying to connect from MacOS 10.14.6 to Ubuntu 18.04.3 but it fails with black screen. NoMachine version is 6.8.1 for the both sides.

    Then I “sudo systemctl stop gdm” followed by “sudo /etc/NX/nxserver –restart”, below is the output:

     

    NX> 162 Disabled service: nxserver.

    NX> 162 Service: nxnode already disabled.

    NX> 162 Disabled service: nxd.

    NX> 111 New connections to NoMachine server are enabled.

    NX> 161 Enabled service: nxserver.

    NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.

    NX> 161 Enabled service: nxd.

     

    Then I get “The session negotiation failed. Error: Cannot create a new display, please contact your system administrator.”

     

    I would appreciate your help. Thank you.

    #24232
    Avatar
    og00r
    Contributor

    Could you please gather some logs for us to check this issue?
    Article on how to collect logs:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    Please enable them, restart the nxservice:
    ‘/etc/NX/nxserver –restart’
    And try reproduce problem.
    Gather logs then.
    After gathering logs, please send them to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.

    But I must ask why did you stop gdm? Is it on purpose? Because now it will try to create virtual session.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.