Black screen when logging into remote machine

Forums / NoMachine for Linux / Black screen when logging into remote machine

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #30275
    Avatarelizabeth.h
    Participant

    Hi there!

    I have been using the free version of NoMachine (6.11.2) on my Windows PC (Windows 7) to connect to a remote Linux machine (running CentOS 7 with GNOME). Since rebooting the remote machine I can log into it using ssh, however, when I use NoMachine to log in I simply get a black screen. I have tried uninstalling and reinstalling NoMachine (including the newest version – 6.12.3), but after all the initial NoMachine set up prompts I still just get a black screen. I have attached the logs, if that is helpful. Any help is appreciated.

    Many thanks,

    Elizabeth

    #30309
    Avatarfra81
    Moderator

    Hi Elizabeth,

    do you mean that you weren’t getting a black screen before the reboot? Is the server a headless machine?

    Server side logs look clean. Can you send also client side logs? Instructions in https://www.nomachine.com/DT10O00163#2.

    #30372
    Avatarelizabeth.h
    Participant

    Yes, that is correct. The server is not a headless machine.

    Please find attached the client side logs as per your download instructions.

    Many thanks, Elizabeth

    Attachments:
    #30411
    Avatarfra81
    Moderator

    Unfortunately relevant logs are missing. Please select the ‘Don’t delete log files on exit’ checkbox as per instructions. Alternatively, you can gather logs before closing the player window, and even better if you could gather again also the server side logs (while the session is still running), so that we will have matching client-server logs. Thanks for cooperation!

    #30603
    Avatarelizabeth.h
    Participant

    Apologies. I think I have done it correctly this time, and have also attached new server side logs. Please find both attached.

    #31336
    AvatarBritgirl
    Keymaster

    Hi, the player logs were not included. Are you sure you ticked the box “Don’t delete logs files on exit’ as outlined here? – https://www.nomachine.com/DT10O00163#2

    Provided that checkbox is ticked, logs will be saved on the connecting client of the affected session.

    We’ve also released version 7 since this topic started, so it would be wise to update to that on both the client and server and try and reproduce.

    #31343
    Avatarelizabeth.h
    Participant

    Hi there.

    Yes, I followed those directions exactly. I have since rebuilt the computer and NoMachine works fine now.

    Thanks for the reply.

     

    #31354
    AvatarCarin
    Participant

    Hi elizabeth,

    thank you for letting us know. Glad the issue is solved.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.