Blank screen on multi-gpu configuration

Forums / NoMachine for Linux / Blank screen on multi-gpu configuration

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31726
    Avatardark_sylinc
    Participant

    I recently installed a new GPU on the host machine.

    The host has the following setup:

    • AMD Radeon HD 7770 1GB hooked to DVI monitor (Mesa drivers, RadeonSI)
    • GeForce 1060 GTX 3GB, not hooked to any monitor (proprietary drivers, ver. 460)
    • xfce desktop
    • Xubuntu 18.04 LTS

    It works fine if I uninstall proprietary drivers.

    I did not try hooking a monitor to the NV card.

    When connecting to this host, I will be received by a blank screen. Ctrl+Alt+T works to either disconnect or exit player, so the client isn’t hung.

    But nothing will be shown (other than white) and input doesn’t work either. The actual machine works fine.

    I’m attaching last entries of the logs. There’s nothing seemingly strange there.

    #31744
    AvatarCarin
    Participant

    Hi dark_sylinc,

    There was an error during the upload of the logs. Can you please send them to forum[at]nomachine[dot]com, referencing the topic as the subject?

    Thanks!

    #31771
    Avatardark_sylinc
    Participant

    Done! Check your inbox.

    I plugged a monitor into the NV card. I can’t yet make it work on Linux, although that looks more like an incompatibility with the TV I used to hook to the card as I get:

    xrandr –auto

    xrandr: Configure crtc 6 failed
    X Error of failed request:  BadValue (integer parameter out of range for operation)
    Major opcode of failed request:  140 (RANDR)
    Minor opcode of failed request:  21 (RRSetCrtcConfig)
    Value in failed request:  0x0
    Serial number of failed request:  82
    Current serial number in output stream:  82
    However this let me go a little further with NoMachine, and now everything is still a white/blank screen, only 1 monitor is detected (out of 2, the other one is connected to AMD card) and interestingly NoMachine doesn’t know the resolution and says that the video codec in use is “unknown” (attached pic).

     

    My guess is that it’s clear NoMachine should be using the AMD card (which has a monitor hooked in), but it is selecting the NV one.

     

     

    #31773
    Avatardark_sylinc
    Participant

    Fixed!

    That last part about unknown codec rang a bell while I was looking this week through NoMachine knowledge base.

    Fixed with:

    “EnableHardwareEncoding 0”

    in /usr/NX/etc/node.cfg as described in https://www.nomachine.com/FR04N03097

    Thanks

    #31867
    AvatarCarin
    Participant

    Hi dark_sylinc,

    Glad to hear the issue has been fixed. Thank you for letting us know!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.