Blank screen when connect – no top corner flap for settings even

Forums / NoMachine for Linux / Blank screen when connect – no top corner flap for settings even

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #14099
    markdesilva
    Participant

    Hi,

    I’ve installed NoMachine’s deb package (latest ‘nomachine_5.2.11_1_amd64.deb’) on several Ubuntu 16.04 (64 bit) machines with no problems, however with this one machine, I am unable to get the desktop. The connection goes through and in the logs I can see the user logged in with “using authentication method password”, however the screen is blank, with no corner flap for settings either. Eventually the whole thing just gives up an “Ooops” with the message “The connection with the server was lost. Error is 138: Connection timed out.” This happens no matter what client I use (Windows, another linux, iPad, etc)

     

    The logs are more curious

    /usr/NX/var/log/nxd.log:

    Info: Server with pid 9743 terminated on Wed Mar 22 14:02:49 2017.
    Info: Server started with pid 9748 on Wed Mar 22 14:02:49 2017.
    Info: Listening for connections on any interface on port 4000.
    Info: Accepting connections from any host with encryption enabled.
    9748 9751 14:02:49 221.720 TcpListener/TcpListener: ERROR! Can’t bind the socket for proto ‘TCP’.
    9748 9750 14:02:49 221.749 TcpListener/TcpListener: ERROR! Can’t bind the socket for proto ‘TCP’.
    9748 9750 14:02:49 221.891 TcpListener/TcpListener: ERROR! In method ‘startTcp()’ context [B].
    9748 9751 14:02:49 221.780 TcpListener/TcpListener: ERROR! In method ‘startTcp()’ context [B].
    9748 9750 14:02:49 221.995 TcpListener/TcpListener: ERROR! Error is 98 ‘Address already in use’.
    Error: Can’t bind the socket for proto ‘TCP’.
    Error: Error 98 ‘Address already in use’.
    9748 9751 14:02:49 222.114 TcpListener/TcpListener: ERROR! Error is 98 ‘Address already in use’.
    Error: Can’t bind the socket for proto ‘TCP’.
    Error: Error 98 ‘Address already in use’.
    Info: Server with pid 9748 terminated on Wed Mar 22 14:02:49 2017.

    * Above lines are repeated many times

    ——————————————————————————————-

     

    /usr/NX/var/log/nxerror.log:

    nxexecRestoreSavedResourceLimits: Info: Can not open resource limits file.
    nxexecRestoreSavedResourceLimits: No such file or directory.
    nxexecExecNode: Info: Cant not restore saved resource limits.
    nxexecRestoreSavedResourceLimits: Info: Can not open resource limits file.
    nxexecRestoreSavedResourceLimits: No such file or directory.
    nxexecExecNode: Info: Cant not restore saved resource limits.
    ——————————————————————————————-

     

    /usr/NX/var/log/nxserver.log:

    2017-03-22 13:57:43 047.239  8039 NXSERVER User ‘administrator’ from ‘192.168.20.2’ logged out.
    2017-03-22 13:57:44 782.851  8777 NXSERVER Starting NoMachine server 5.1.62 and services.
    2017-03-22 13:57:44 854.885  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8807/8807’ finished with exit code 98 after 0,012 seconds.
    2017-03-22 13:57:44 865.593  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8816/8816’ finished with exit code 98 after 0,008 seconds.
    2017-03-22 13:57:44 886.303  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8820/8820’ finished with exit code 98 after 0,019 seconds.
    2017-03-22 13:57:44 902.622  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8836/8836’ finished with exit code 98 after 0,013 seconds.
    2017-03-22 13:57:44 926.195  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8841/8841’ finished with exit code 98 after 0,021 seconds.
    2017-03-22 13:57:44 937.259  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8846/8846’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:44 948.277  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8850/8850’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:44 960.628  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8854/8854’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:44 972.557  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8858/8858’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:44 984.324  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8862/8862’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:44 996.214  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8866/8866’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 007.155  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8872/8872’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 018.624  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8876/8876’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 029.061  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8880/8880’ finished with exit code 98 after 0,008 seconds.
    2017-03-22 13:57:45 039.489  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8884/8884’ finished with exit code 98 after 0,008 seconds.
    2017-03-22 13:57:45 051.537  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8888/8888’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 062.313  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8892/8892’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 072.574  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8896/8896’ finished with exit code 98 after 0,008 seconds.
    2017-03-22 13:57:45 084.226  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8900/8900’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 094.644  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8904/8904’ finished with exit code 98 after 0,008 seconds.
    2017-03-22 13:57:45 105.462  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8908/8908’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 117.294  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8912/8912’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 128.237  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8916/8916’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 139.185  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8920/8920’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 151.541  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8924/8924’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 163.193  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8928/8928’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 178.033  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8932/8932’ finished with exit code 98 after 0,012 seconds.
    2017-03-22 13:57:45 189.498  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8936/8936’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 200.945  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8940/8940’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 212.441  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8944/8944’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 223.686  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8948/8948’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 235.123  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8952/8952’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 245.891  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8956/8956’ finished with exit code 98 after 0,008 seconds.
    2017-03-22 13:57:45 257.792  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8960/8960’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 268.525  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8964/8964’ finished with exit code 98 after 0,009 seconds.
    2017-03-22 13:57:45 280.229  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8968/8968’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 292.448  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8973/8973’ finished with exit code 98 after 0,010 seconds.
    2017-03-22 13:57:45 305.631  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8981/8981’ finished with exit code 98 after 0,011 seconds.
    2017-03-22 13:57:45 319.456  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8985/8985’ finished with exit code 98 after 0,012 seconds.
    2017-03-22 13:57:45 333.701  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘8989/8989’ finished with exit code 98 after 0,012 seconds.
    2017-03-22 13:57:45 350.232  8777 NXSERVER WARNING! Process ‘/usr/NX/bin/nxd’ with pid ‘9003/9003’ finished with exit code 98 after 0,015 seconds.
    2017-03-22 13:57:45 350.480  8777 NXSERVER WARNING! Reached maximum NXD restart counter.
    2017-03-22 13:57:45 585.521  8824 NXNODE   WARNING! Not recognized reply from nxagent <Connect>: .

    I can’t find any info on google other than a single post which says a reboot solved his issue. Rebooting did not solve my issue. Any help would be most appreciated. Logs attached.

    Thank you.

    Attachments:
    #14105
    brotech
    Participant

    Hello Mark,
    it looks similar as the issue described in another thread, which happens on Kubuntu 16.04 LTS.
    The problem probably is related to internal network stack, and so far we have no clue about solution or even reason.

    Could you please attach also logs from /usr/NX/var/log/node directory ? It will help to confirm if
    is the same issue. Then, could You show a result of following system commands as:

    cat /etc/hosts
    ifconfig
    ping -c localhost
    uname -a
    

    There is anything different which you are using on that problematic ubuntu host? Iptables, apparmor, network card etc ?

    #14143
    markdesilva
    Participant

    Hi sorry for the late reply, didn’t get any emails notifying me there was a response.

    Nothing different on this machine. In fact, I had NoMachine running fine on this same hardware previously. All I did was replace the hard drive (old hard drive was running ubuntu 14.05) and install the latest Ubuntu and patch it will all the recommended app and security patches, just like all my other machines. All the other machines run nomachine fine, its just this one machine that exhibits this issue. Iptables currently allows all traffic, no restrictions (until this issue is solved, this machine is not running anything other than whats supposed to run after a clean install).

    Also, I’ve tried putting back the old hard drive (running ubuntu 14.05) and running NoMachine and it connects just fine. Just this new install.

    Anyway for the output requested:

    # cat /etc/hosts
    127.0.0.1       localhost
    127.0.0.1       localhost.localdomain

    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    # ifconfig
    eno1      Link encap:Ethernet  HWaddr A4:02:B9:25:ef:d0
              inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: ffe80::5136:e219:1775:7fac/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2086320 errors:0 dropped:0 overruns:0 frame:0
              TX packets:886848 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:921274076 (921.2 MB)  TX bytes:384847275 (384.8 MB)
              Interrupt:20 Memory:f7d00000-f7d20000

    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:3255346 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3255346 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1
              RX bytes:1389571225 (1.3 GB)  TX bytes:1389571225 (1.3 GB)

     

    # ping -c 3 localhost
    PING localhost (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.032 ms
    64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.048 ms
    64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.062 ms

    — localhost ping statistics —
    3 packets transmitted, 3 received, 0% packet loss, time 1998ms
    rtt min/avg/max/mdev = 0.032/0.047/0.062/0.013 ms

    # uname -a
    Linux pan01 4.4.0-67-generic #88-Ubuntu SMP Wed Mar 8 16:34:45 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

    #14145
    markdesilva
    Participant

    I replied but my post is being held for moderation?

    #14152
    Britgirl
    Keymaster

    I replied but my post is being held for moderation?

     

    We moderate everything – unfortunately trolls are frequent as are spammers 😉

    #14157
    brotech
    Participant

    Hello,
    everything looks fine so far. Please attach mentioned /usr/NX/var/log/node directory.
    Could You also try to connect locally using nxplayer and then sent to us again nxd.log
    file ? (By locally I mean, running nxplayer on problematic host and connect to 127.0.0.1
    using it).

    #14158
    markdesilva
    Participant

    Ah ok, sorry I was confused because my initial post went through immediately. Thanks!

    I have uninstalled and reinstalled versions 4.x and 5.1 of NoMachine and still get the black screen without the flap. Reinstalled 5.2 and still the same issue. As a temporary fix until someone has a solution to this, I’ve installed [another product]. Its gets the job done and is functional but I still prefer NoMachine, so hope someone can figure out this issue.

    Attached logs from the client side.

    Thank you.

    #14162
    markdesilva
    Participant

    Did a clean install of ‘nomachine_5.2.11_1_amd64.deb’, after removing /usr/NX and letting the install recreate everything.

    Tried to connect from my Windows client, same black screen issue (no corner flap), eventually kicks out with “Error 138” some connection to server lost thing.

    Tried from localhost as requested, this time blank white screen (no corner flap), kicks out with “Error 110” same connection to server lost thing.

    The node directory and nxd.log are zipped and attached.

    Thank you.

    Attachments:
    #14325
    markdesilva
    Participant

    Hi was wondering if theres any break through with this issue? Thank you.

    #14342
    kroy
    Contributor

    Do you have some specific iptables settings? Can you show here output sudo iptables -L command?

Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.