Blurry coloured font on Version 7.6.2

Forums / NoMachine for Linux / Blurry coloured font on Version 7.6.2

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #33831
    Avatararea51
    Participant

    Currently, I’m using NoMachine to access a CentOS 7.9 physical machine on my local network. After a terminal is opened and using Vim to do coding, if the Vim syntax is turned on then display area around current cursor becomes a bit blurry when the cursor moves. It will back to normal after a few seconds if the cursor stops. Another annoying part is the color of the area changes at the same time.

    Both the server and client are on Version 7.6.2.  All default settings and Xfce4 is used as GUI interface.

    I have tried Windows 10 & Mac Catalina, both have the same problem. Turn off UDP does not help. Seems only the terminal window has this issue.

    CentOS 7.9.2009
    Xfce4
    NoMachine 7.6.2, NX

    #33852
    Avatararea51
    Participant

    Another test proves that the blurry is not limited to terminal window. In a code analysis tool, the source code has similar syntax highlight as Vim, blurry happens when scrolling up or down. The difference is blurry making color of fonts deeper on light-colored background of the code analysis tool while color getting lighter on dark background of Vim. The blurry gradually disappear in about 2 seconds under all cases. Network bandwidth is high because the client and server are under the same LAN.

    One more thing to add, the most annoying part is that fonts having red tone such as magenta is affected the most, affect on cyan is much less noticeable. No blurry at all if white on black or black on white.

     

    #33860
    Avatararea51
    Participant

    Did more test, switch to gnome does not help, but set the terminal font bigger helps a lot. Although font color still changes if the cursor moving around it, the blurry almost unnoticeable. The most annoying scenario is xterm, default fonts, black background and gray foreground. Under sharp small xterm fonts, when the block cursor moving around magenta text in a Vim windows, the blurry is quite bad.

     

    #33872
    Avatarfra81
    Moderator

    Hi,

    colors generally need to be sub-sampled before they are fed to video encoders (typically from RGB to YUV format). This is particularly visible with bright colors (especially red) on dark backgrounds. For this reason, NoMachine performs an additional encoding pass to “fix” the colors (see https://knowledgebase.nomachine.com/FR03M02907). This is done progressively to not saturate the available bandwidth.

    To alleviate this effect you can set the Display quality to the maximum level in the session menu panel, so that color refinement will happen faster. To make it even faster, you can check the ‘Disable multi-pass display encoding’ option in the advanced display options.

    #33874
    Avatararea51
    Participant

    After changing the quality to maximum and disable multi-pass display encoding, looks like the blurry is improved and the color changes also recovered faster. The only artifact left is that the intermittent color change on red text is still quite big and annoying. I’m using a 43″ 4k monitor, so Xterm default font size is just what I prefer on that size monitor.

     

    #33898
    Avatararea51
    Participant

    Don’t know if this help:

    Adding ProxyExtraOptions “pack=16m-png”

    The red fonts always stay blurry as the attached picture shown as if the anti-aliasing was on while the white fonts is in pixel-perfect shape. Is this actually a bug on the server side? Because base on my understanding, the above option turned off sub-pixel sampling and should always provide perfect pixel font. Why it behaves just the opposite always stay blurry?

    #34029
    Avatarfra81
    Moderator

    Adding ProxyExtraOptions “pack=16m-png”

    This option is only effective in virtual desktop sessions, when the ‘X11 vector graphics mode’ is enabled. Virtual desktops are only available for products in the Terminal Server family (e.g. NoMachine Workstation), of which you can download an evaluation version.

    Because base on my understanding, the above option turned off sub-pixel sampling

    To be precise, it would turn off the chroma subsampling that is introduced by the colorspace conversion from the YUV to the RGB format, as part of the encoding process. It doesn’t change the aliasing setting used by remote applications when rendering fonts.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.