Browser access for a Windows AWS machine

Forums / NoMachine for Windows / Browser access for a Windows AWS machine

This topic contains 1 reply, has 2 voices, and was last updated by Avatar Tom 1 week, 3 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #23159
    Avatar
    moustafa_nabil3
    Participant

    Hi all,

    • I have created a Windows Server 2019 Machine on AWS
    • I accessed it using Windows Remote Desktop connection, then I downloaded and installed NoMachine Enterprise Desktop (the evaluation version)
    • I also added a rule for the inbound security group:
      • TCP, port: 4000 from any IP
      • TCP, port: 4080 from any IP

    But whenever I try to access the machine using chrome on my laptop (http://<machine public name>:4080), I got:

    • Either: connection refused message
    • Or: <IP> took too long to respond

    I am not sure where is the problem.

    Another trial I did was:

    • Login to the machine using Windows Remote Desktop
    • Open google chrome on this remote machine
    • Try to access the machine using: http://localhost:4080
      • It connects and asks me for user name and password.
      • But I can’t figure out which username and password I should use. It always give the message like “Authentication failure”.

     

    This means, mot probably, there is a problem in Amazon AWS security group, or Amazon firewall.

    Does any one know settings we need to access a Windows machine or Linux machine using the browser?

    #23245
    Avatar
    Tom
    Participant

    Hello,

    please connect to your Windows via https protocol.

    To do this please add to security group two rules:

    Custom UDP for port 4443 for source set your client IP.
    Custom TCP for port 4443 for source set your client IP.

    After this you can connect to Windows via browser on your client using https://machine_ip:4443
    Please use the same username and password as you do an for RDP connection.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.