Browsers render slowly in virtual session

Forums / NoMachine for Linux / Browsers render slowly in virtual session

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26013
    Avatarzaggynl
    Participant

    Host:
    OS:Ubuntu 18.04
    NoMachine version: 6.9.2
    DE: XFCE

    Client:
    OS: Windows 10 1909
    NoMachine version: 6.9.2

    After I plugin any monitor and restart the X session the browsers render quickly again.

     

     

    #26092
    Avatarfra81
    Moderator

    Hi,

    it is possible that the X server is working with reduced performance while in headless mode. You can try to turn it off so NoMachine will create its own X virtual frame buffer:

    # sudo systemctl stop display-manager

    To disable automatic start and make the change persistent:

    # sudo systemctl disable display-manager

    Then restart the NoMoachine service:

    # sudo /etc/NX/nxserver --restart

    #26101
    Avatarzaggynl
    Participant

    Thank you, will give this a go next time and will report back.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.