Can connect one way but not the other

Forums / NoMachine for Mac / Can connect one way but not the other

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #14854
    AvatarRiTides
    Participant

    I just installed the latest version of the software on a Windows 10 desktop and a Macbook Air laptop on the same local wifi network.

    I can connect from the desktop to control the laptop remotely just fine. But my purpose for installing was to do the opposite – to control the desktop from the laptop.

    It seems to me the problem is with detecting the other computer – the desktop detects the laptop, and it shows up and I can just click on it to connect. The laptop does not detect the desktop (“No computers were found on your local network”) and even if I manually enter the IP address, it does not connect.

    I’ve temporarily disabled Avast antivirus on the desktop, and turned off Windows Defender, but to no avail. Help?

    #14865
    Avatarkroy
    Contributor

    Disabling the anti-virus shouldn’t be necessary.

    Did you reboot Windows after installing NoMachine? It’s necessary for proper operation of the nxserver.

    #14871
    AvatarRiTides
    Participant

    I did do that, and I’m also going to try using an ethernet cable on the Windows machine (right now it’s a wireless dongle) and “restarting” the Mac (which I didn’t think was necessary). But neither of those seem to make sense since I can see the Mac with my Windows PC and control it… just not the other way!

    Any help would be really appreciated, I’m stumped =/

    #14878
    AvatarBritgirl
    Keymaster

    Indeed, disabling the antivirus shouldn’t be necessary, but in this particular case there is a bug specifically with AVAST which is conflict with NoMachine, and disabling isn’t enough. You can see the details here: https://www.nomachine.com/TR03O07676.

    Please use the notify me tool to know when a fix is available.

    #14936
    AvatarRiTides
    Participant

    Britgirl, thank you very much (and sorry I just saw your response – I had given up on solving this!).

    Is there any kind of work-around if I’m willing to take drastic measures – for example, completely uninstalling Avast and using a different antivirus? That is indeed the one I’m using, so that’s the bug I’ve run into!

    #14946
    AvatarCato
    Contributor

    Hello RiTides,

    Please, check if lsass.exe process is running in protected mode.

    To do so:

    1. Download and install Process Explorer using this link:

    https://technet.microsoft.com/en-us/sysinternals/processexplorer.aspx

    2. Start Process Explorer as Administrator.

    3. Double click on lsass.exe process and check the value of ‘Protected’.

    If lsass is NOT working in protected mode gather the logs using this instructions:

    https://www.nomachine.com/DT07M00098

    and send them to forum[at]nomachine[dot]com.

    If lssass is working in protected mode, you can completely uninstall Avast antivirus, or you can try to use alternative antivirus software. From what we know, NoMachine works fine with AVG antivirus when ‘Disable antivirus self protection’ option is used.

    #14966
    Avatarmhnj7
    Participant

    Any recommendations for another Antivirus program that doesn’t have this problem?

    #14967
    Avatarmhnj7
    Participant

    Nevermind…can delete question. I see AVG was recommended

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.