Can hear myself when using microphone

Forums / NoMachine for Windows / Can hear myself when using microphone

Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #21260
    Echoo0o
    Participant

    Hi all, I recently installed NoMachine on a remote server to try and use for VoIP, and everything works as intended, except that when I enable the microphone from NoMachine I can hear myself. Is there a way to disable this?

    #21278
    mkub
    Participant

    Hi ,

    Do you hear echo sound after enabling the microphone, before or after starting VoIP session? It is possible that the microphone is redirected to the sound output. Please check your system’s audio settings and make sure that NoMachine’s Microphone is not an audio output. What is your default output and input?

    If settings are fine: Can you record audio input using NoMachine Microphone and compare it with audio output? Are the streams the same?

    What is your operating system?

    Thanks
    mkub

    #21282
    Echoo0o
    Participant

    Hi mkub,

    I hear the echo only when using the microphone on NoMachine after starting the VoIP session. It echoes in Discord, Skype and the Windows microphone setup.

    On my remote server I am using Microsoft Server 2016 and my local machine uses Windows 10. My headphones are my output device on my local machine, and I set NoMachine to disable sound on the server while streaming it back to me directly.

    The default IO on my local machine is my USB headset, while the default IO on the server are NoMachine’s microphone redirection and speakers.

    I checked whether the server or local machine is listening to the microphone and recording it, and neither of them were.

     

    Thank you

    #21306
    Echoo0o
    Participant

    I just tried reinstalling the audio drivers but I still have the same issue. Could any NoMachine setting be causing this?

    #21308
    mkub
    Participant

    Hi Echoo0o,

    We are not able to reproduce your problem. Please check your audio settings. On the server default recording device should be set to NoMachine Microphone Adapter and default playback device should be set to speakers / headphones, it has to be different from NoMachine Microphone Adapter. On your client side, playback and recording default devices should be set to your USB headset. You can also verify which device is being in use during VoIP session.

    You may also try to check if microphone in session works properly on this website:
    https://www.onlinemictest.com/

    If you have proper settings and despite this you are still unable to record audio stream with microphone and you hear echo – try reinstalling NoMachine.

    Thanks,
    mkub

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.