Can NoMachine be restricted to ports 80 and 443?

Forums / General Discussions / Can NoMachine be restricted to ports 80 and 443?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9943
    okdude
    Participant

    I’m trying to evaluate my options to be able to connect NoMachine to a remote Linux Ubuntu running its desktop GUI via Amazon’s AWS service (or something similar).  The client side will be behind a very restrictive firewall that only allows traffic on ports 80 and 443 to exit the LAN to the public.  I’ve been reading the various docs and have looked at both the free version and also the Cloud version to see if either would actually work in this configuration.  What I’m hoping for is either the NoMachine client or a web browser client can reach my remote machine via 80 or 443.

    Does anyone know if NoMachine can be configured to work within this limitation?  There won’t be any other hosted websites running that would need 80/443 on this host/remote machine…but the intention would be to be able to remote in and then be able to use a web browser to also connect out to the internet for normal operations but feed the info/display back through NoMachine to the client.

    Any feedback would be greatly appreciated.

     

    #9960
    irek
    Participant

    You can change the port where the Cloud Server is listening on from the Services panel in the Server preferences GUI:

    https://www.nomachine.com/DT11M00107#2

    You can also edit directly the configuration files. Assuming you want to change the default ports from 4080/4443 to 80/443:

    1. shutdown nxhtd

    #nxserver –stop nxhtd

    2. change configuration files:

    in htd.cfg:

    replace


    Listen 0.0.0.0:4080
    Listen 0.0.0.0:4443 https

    with


    Listen 0.0.0.0:80
    Listen 0.0.0.0:443 https

    – in cloud.inc


    <VirtualHost 0.0.0.0:4443>

    with


    <VirtualHost 0.0.0.0:443>

    and


    <VirtualHost _default_:*>
    RewriteEngine on

    ReWriteCond %{SERVER_PORT} !^4443$
    RewriteRule ^/(.*) https://%{SERVER_ADDR}:4443/nxwebplayer [R,L]
    </VirtualHost>

    with

    <VirtualHost _default_:*>
    RewriteEngine on

    ReWriteCond %{SERVER_PORT} !^443$
    RewriteRule ^/(.*) https://%{SERVER_ADDR}:443/nxwebplayer [R,L]
    </VirtualHost>

    3. start nxhtd

    #nxserver –start nxhtd

    Alternatively, you can use the NoMachine native client in that configuration by following the suggestion in this post:

    https://www.nomachine.com/forums/topic/changing-nx-port-number-from-4000-to-80#post-3616

    #9968
    okdude
    Participant

    Irek,

    Thanks for the info.  I’ll try and play with that.

    When you say, “alternatively…use NoMachine native client”, do you mean using the Cloud version in native configuration or did you mean the the Free version of NoMachine and the suggestion in the post?  I read the other post and I’ll explore that option as well.

    Do you believe I could use the Free version of NoMachine on the Linux server in the same conditions of 80/443 limits?  And if so, are your tips applicable in the same way?

    I’ve tried testing the install as is from a client that doesn’t have the port restrictions and I’m having some issue where I can get it to initially connect, authenticate, but when I select the desktop…it just spins waiting and never comes back.  So, I’ve got some other issue going on as well.  I’m not sure I have all the AWS inbound port configuration setup appropriately, but I did open them all just to test and had the same spinning, no response issue after authenticating user/pass.

    Scott

    #9987
    irek
    Participant

    Hello Scott,

    I meant using the NoMachine Player (the native client) instead of the Web Player (the web application), regardless of what products you decide to install on client or server side. To use that, you would need to try the suggestion in that post.

    Regarding the further problem with the spinning connection, we will need debug NoMachine Cloud server logs to investigate further. Please follow the instructions here:

    https://www.nomachine.com/DT07M00098#1

    especially point 1.3:


    1.3. If you have a Cloud Server installed and the problem affects sessions by the web:
    Edit the /usr/NX/etc/cloud.cfg file. Uncomment and set the following:

    SessionLogLevel 7

    Send them to forum[at]nomachine[dot]com

    • This reply was modified 5 years, 11 months ago by irek.
Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.