Cannot connect – connection times out

Forums / NoMachine for Linux / Cannot connect – connection times out

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #13888
    Avatarmikew
    Participant

    I am trying to connect to windows 10 over internet from debian xfce  4.12.2 using latest NoMachine 5.2.11 and win 5.2.11_1.

    I have edited server.cfg to allow uPNP

    Gui reports error 110

    When I try from reverse direction (win to linux) I get error 138

    What am I doing wrong?

    Attached session log from linux.

    Thanks

    MikeW

    #13910
    AvatarBritgirl
    Keymaster

    Can you submit the attachment to forum[at]nomachine[dot]com?

    #13970
    Avatarkroy
    Contributor

    We noticed from the logs that you are using your local network IP. Is that what you want or do you want to connect over the Internet?  Do you have problems connecting on a local network (same home network or LAN at work)?

    If you want connect over internet you need to connect with your external IP. Here you can find basic information about using NoMachine https://www.nomachine.com/getting-started-with-nomachine. Please check out section: “Using NoMachine for remote access to a computer over the internet”.

    #13980
    Avatarmikew
    Participant

    From the “Using NoMachine for remote access to a computer over the internet”.

    “….Open NoMachine from the programs or applications menu. If you want to connect to this computer over the Internet, you will need to know its external IP address and its port number. NoMachine will detect this for you and will display it, like this: nx://151.1.192.128:29382 (Fig.8). Write this information down. If a port number is not displayed next to the external IP, NoMachine has detected that you don’t need it in the next phase.| ….”

    It seems NoMachine only detected and displaid the internal address and I dumbly just took that as the external.

    Will try using external addresses tomorrow.

    Thanks tons for helping with this.

    MikeW

    #13982
    Avatarmikew
    Participant

    My external IP changes everytime I query it! Can I use something like no-ip and put in something like “myhost.mydomain.com” instead of the discreet IP address?

     

    #13998
    Avatarkroy
    Contributor

    Yes. If that changing IP isn’t caused with problems on the router, modem or etc. – it’s a good idea to use Dynamic Domain Name System service.

    #14028
    Avatarmikew
    Participant

    Still cannot connect – now using ddns I can do nslookup and ping my linux from windows so ddns working but connection still fails with error 138 from windows side. Session log shows that the problem is IPv6 cannot resolve the address. Since I disabled IPv6 in the adapter properties I don’t know why NoMachine is trying to use IPv6 and I cannot turn it off in the GUI and since I have discovered another product that works and is not teamviewer,  I am afraid that I will not be using NoMachine unless and until it also works over the internet without spending time scratching my head and wasting your time trying to help. But thanks for the help anyway – I appreciate it.

    MikeW

    #14034
    Avatarkroy
    Contributor

    …I can do nslookup and ping my linux from windows so ddns working but connection still fails with error 138 from windows side.

    Are you connecting via NoMachine using your_domain_name as Hostname and 4000 as Port? You need to configure your router to forward a suitable port to your local IP port 4000. Then connect via NoMachine using your_domain_name as Hostname and a suitable port.

    I don’t know why NoMachine is trying to use IPv6 and I cannot turn it off in the GUI.

    At the moment there is no way to disable searching for IPv6 in the NoMachine, but you should be still able to use IPv4.

    …since I have discovered another product that works…

    Can you say what is the product? Did you forward port to using it? If yes – which port?

    #14071
    Avatarmikew
    Participant

    Product is [removed]. No port forwarding required. One address typed in and you are connected.

    #14076
    AvatarBritgirl
    Keymaster

    In the near future it will be possible to eliminate these problems of having to know your IP address by using our Network (was Anywhere) service which is in its final testing stages. If you want to sign up to the beta programme, let us know 🙂

    #14088
    Avatarmikew
    Participant

    Yes, please let me know when beta available.

    Thanks

    MikeW

    #14098
    Avatarwhoehenrieder
    Participant

    I would also be interested in the Network (Anywhere) beta.

    I’ve been anxiously awaiting this feature for some time.

    Regards,

    Werner H.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.