Cannot connect to computer over public IP

Forums / NoMachine for Windows / Cannot connect to computer over public IP

Tagged: 

  • This topic has 1 reply, 2 voices, and was last updated 6 years ago by kroy.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #11868
    Rawb
    Participant

    I am using NoMachine 5.1.26 on my home network. I have two computers, one a laptop and one a desktop that can each connect to each other with no problem as long as it’s over the internal private network. I also used to be able to connect to my Desktop from the Laptop over the internet (using DDNS and forwarding ports through my router).

    Recently I had to replace my router and, since then, I have been unable to connect over the internet. I have been able to track the issue down to the fact that, for some reason, NoMachine is attempting to use IPv6 to look up the address even though ipv6 is not even enabled on the laptop.

    How can I force NoMachine to use IPv4 for its DNS lookups (which it apparently used to do because I’ve never had an IPv6 address bound to my DDNS name).

    Attached is the log from my Laptop.

     

    #11874
    kroy
    Contributor

    At the moment there is no way to disable searching for IPv6 in the NoMachine, but you should be still able to use IPv4. Please check again your IP numbers and that you have correctly configured port forwarding. Might you consider enabling UPnP map forwarding? There is instruction how to connect to NoMachine when the server is behind a NAT router or a firewall: https://www.nomachine.com/AR11L00827.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.