Cannot connect to headless Raspberry Pi 3

Forums / NoMachine for Raspberry Pi / Cannot connect to headless Raspberry Pi 3

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10917
    mat91
    Participant

    I’m trying to remote connect to my Raspberry Pi 3 BMC2837 (with NoMachine ARMv7 version 5.1.9)  from my macbook (with NoMachine for OS X 5.1.9) via my LAN.

    I have the setup working if I first connect a monitor (HDMI) to my Pi before starting it up. Then I don’t have to touch anything on the Pi, and I can go ahead and successfully remotely connect from my macbook.

    However, if I start the Pi up without a monitor connected to it, then I cannot connect to it and get returned to me “Could not connect to server. Error is 64: Host is down”. This seems pretty self-explanatory, but I don’t know what I should try.

    My macbook has OS X El Capitan 10.11.3

    My pi has Raspbian Jessie

    Any suggestions would be appreciated 🙂

    #10940
    Trf_517
    Participant

    Hi!

    First off, I need to make sure your Raspbian is configured properly for the headless run.

    In the /boot/config.txt have you uncommented the ‘force_hdmi_hotplug=1’?

    Does your Raspbian automatically go to desktop after startup? Or do you have to type ‘startx’ in the terminal to run X server after startup?

     

    #10955
    mat91
    Participant

    Hi,

    I have now, and still get error 64. Do I have to uncomment anything else in config.txt in addition to this?

    Yes, it goes directly to desktop and logs itself in. So when I have a monitor plugged in I just plug in the power, and after a minute or two I can connect to it using nomachine, without touching the Pi.

     

    #10960
    Trf_517
    Participant

    Ok, thanks for the response.

    The ‘force_hdmi_hotplug’ forces PI to act like there is monitor plugged (so there is no switching to really low resolutions).

    A bit odd is the part where the server starts with the OS when monitor is plugged in. ARMv7 packages do not work properly on Raspbian, which is mostly ARMv6 compatible. To check if it works connect via ssh to your Raspberry and try to manually start the nxserver:

    ssh <pi_username>@<pi_local_IP_address>

    Once you are connected:

    sudo /usr/NX/bin/nxserver –startup

    If you will get lots of messages about incorrect GLIBC, then you should install ARMv6 package on your Raspbian (if you would like to use ARMv7  package, consider using Ubuntu MATE, on Raspberry PI3 it runs quite efficiently).

     

    #11074
    mat91
    Participant

    Hi,

    I got it to work with ARMv7. I think that I just have something funny with my network settings that it doesn’t consistently connect to the wifi.

    It is now connected via a LAN cable to my router, and I can consistently connect to it. I’ll report back once I figure out what is causing my RPi to have issues connect to the wireless.

    Thank you for your help!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.