Cannot connect with non-root account

Forums / NoMachine for Linux / Cannot connect with non-root account

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #30041
    Avatarcement_head
    Participant

    Server is Ubuntu 16.04.7 LTS running latest version of NoMachine.

    Clients are either Ubuntu 18.04.5 LTS; or Windows10, or Mac O/S (version unknown; recent).

    Server is a workstation with multiple login accounts.

    Clients can connect to the server without issue is they use the Administrator account in the NoMachine connection dialogues; then once connected they can sign-in/login to the individual User profile using their User credentials.

    Clients cannot connect to the server is they attempt to use their User profile connections in the NoMachine connection dialogues.

    Is this expected behaviour?  If not, how do I enable connecting to the server using User profile logins with the NoMachine dialogue(s).

    #30099
    AvatarBritgirl
    Keymaster

    Can you specify what NoMachine software is installed on server – the free version, Workstation, something else?

    What error message/dialog is being shown when non-root users try to connect? Screenshots would be helpful.

    #30094
    Avatarcement_head
    Participant

    Really?  Is there no one from the company here to help?

     

    #30104
    AvatarBritgirl
    Keymaster

    See above. Also check whether those users can log in to the remote host by plain SSH.

    #30107
    Avatarcement_head
    Participant

    No, non-privileged users cannot connect via SSH

    #30108
    Avatarcement_head
    Participant

    Free version; “Authentication Denied”

    #30111
    AvatarBritgirl
    Keymaster

    No, non-privileged users cannot connect via SSH

    Then it’s a problem with how you have configured authentication on your system if even with plain SSH users are getting authentication errors.

    NoMachine relies on the authentication settings configured on the system, so if that’s not set properly, it won’t work for NoMachine either.

    Check this and then rectify. Then try again with NoMachine.

    #30112
    Avatarcement_head
    Participant

    non-privileged SSH does not work at all.

    How do I fix this?  (And shouldn’t the NoMachine installer fix this on installation)?

    #30115
    AvatarBritgirl
    Keymaster

    How do I fix this?

    Questions about how you should configure your Ubuntu system and SSHD would be better off in the Ubuntu forums 😉

     

    And shouldn’t the NoMachine installer fix this on installation?

    How would NoMachine be able to do that if it doesn’t know a priori exactly what you did to your system and how you did it? Besides the fact that altering a systems configuration during installation would be unacceptable to most users. NoMachine adapts to what the system’s configuration is set to do when it is installed.

    BTW, just a note on SSH support in the free version should you wish to connect using SSH once you’ve fixed your system’s configuration; the free version supports connections via NX. If you want to connect using SSH, you should try the Enterprise Desktop product.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.